3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home | Profile | Register | Active Topics | Members | Search | GoogleSearch | FAQ | 3dfxzone.it
Username:
Password:
Save Password
Forgot your Password?

 Index
 3dfx Hardware & Software
 Voodoo2 Setup and tweaking
 voodoo2 and dx9
 New Topic  Reply to Topic
 Print topic

Next Page
Author Previous Topic Topic Next Topic
Page: of 2

cy717
Novice

3 Posts

Posted - 24/12/2003 :  12:19:50  Show Profile  Visit cy717's Homepage  Reply with Quote
I'm currently using a voodoo2 card. but when i installed dx9, it stopped working, i used to be able to play games like halflife and such but now, any game that needs either D3D or Glide to work doesn't run. and when i run dxdiag, it says the direct3d isn't supported by the voodoo2. i'm using FastVoodoo2 4.0 Gold Edition drivers

is there a way to fix this, or is there a way for me to uninstall directx 9, and reinstall directx 8, which worked perfectly fine?

metl4evr
Novice

2 Posts

Posted - 25/12/2003 :  21:19:16  Show Profile  Visit metl4evr's Homepage  Send metl4evr a Yahoo! Message  Reply with Quote
I have a problem similar to that. my system when i try to run Quake 2 tells me that direct 3d isnt even installed, and makes me reinstall 9, which does NO good whatsoever. I can't even get into the CD so i can run it manually. They DO have things called DirectX busters, just do a search and download one. Not sure where u can get DirectX 8 or 7.


Go to Top of Page

cy717
Novice

3 Posts

Posted - 26/12/2003 :  05:41:22  Show Profile  Visit cy717's Homepage  Reply with Quote
Alrite.. I ran DirectX Buster and reinstalled directx 8.1. everything works beautifully now. cheers mate
Go to Top of Page

Glide
Web Admin

Napoli


24413 Posts

Posted - 28/12/2003 :  16:25:22  Show Profile  Visit Glide's Homepage  Reply with Quote
- cy717

Which DirectX 9 version did you install?

Welcome to 3dfxzone.it Community

Join us! | 3dfxzone.it | hwsetup.it | forumzone.it
Go to Top of Page

cy717
Novice

3 Posts

Posted - 28/12/2003 :  18:49:39  Show Profile  Visit cy717's Homepage  Reply with Quote
er i dunno.. i got it off the microsoft webbie.
hmm why?
Go to Top of Page

Simo
Novice

1 Posts

Posted - 04/09/2004 :  16:26:23  Show Profile  Visit Simo's Homepage  Reply with Quote
I have the same problem.
In DXDIAG there is D3D, and AGP texture acceleration not supported. Why? And how can I switch it ON?
In W98SE everything works fine. But in W2000 no.
Go to Top of Page

Nightbird
Moderator



1938 Posts

Posted - 04/09/2004 :  17:19:50  Show Profile  Visit Nightbird's Homepage  Send Nightbird a Yahoo! Message  Reply with Quote
A Voodoo 2 and the Win2k kernel ?
The Win2k kernel thks to MS doesn't support the addon cards (like the V2) so no D3D acceleration is available (this is the difference with Win9x) and no Voodoo Card supports the Agp texture acceleration (whatever the OS).
So in short under Win2k, a Voodoo 2 = Glide and OpenGl.

______________________________________________

In-ter-ac-tive :
The way video games were always meant to be played
______________________________________________

Welcome to 3dfxzone.it Community
_____________________________

Edited by - Nightbird on 10/09/2004 22:39:14
Go to Top of Page

avengerx
Novice

Brazil


23 Posts

Posted - 07/01/2005 :  21:57:03  Show Profile  Visit avengerx's Homepage  Send avengerx an ICQ Message  Click to see avengerx's MSN Messenger address  Reply with Quote
DirectX 9 came like a beast to frag every 3D card... even that which 'simulated' 3D cards... I own a sis530 with a voodoo2 sli schema, when I was installing the v2 here, I updated dx also, to dx9.0c... and saw every 3D support to come out... until I've put the fastv2 to work, with some problems... When I realised that soul reaver was with less effects than my old sis530 (although better fps), I swept dx9 and carefully reinstalled dx8.1... now I get the sis530 to 'emulate' my 3D for the games as it always worked, and v2 does the effects it was not doing before in some games!.. Also, dxdiag now displays the 3D tests... Dxdiag from dx9 always returned error even for the v2 card although it worked for some d3d games. DX9 really messed up things...

Edited by - avengerx on 07/01/2005 21:58:09
Go to Top of Page

Avenger
Novice

38 Posts

Posted - 08/01/2005 :  02:55:08  Show Profile  Visit Avenger's Homepage  Send Avenger an ICQ Message  Reply with Quote
I wouldn't want my V2 to handle D3D nowadays. It sits in my PC to keep Glide support. D3D and OGL are being handled by my Radeon.
Go to Top of Page

Nightbird
Moderator



1938 Posts

Posted - 08/01/2005 :  20:16:58  Show Profile  Visit Nightbird's Homepage  Send Nightbird a Yahoo! Message  Reply with Quote
quote:
Dxdiag from dx9 always returned error even for the v2 card

About the V2, this is "normal" now.
Only Dx under DirX8.1/Dix7 etc... will work correctly for now.
Seems that DirX9 doesn't support the addon cards.

______________________________________________

In-ter-ac-tive :
The way video games were always meant to be played
______________________________________________

Welcome to 3dfxzone.it Community
_____________________________
Go to Top of Page

NeoRAGERx
Novice

Romania
22 Posts

Posted - 12/01/2005 :  20:26:39  Show Profile  Visit NeoRAGERx's Homepage  Send NeoRAGERx a Yahoo! Message  Reply with Quote
So this is "normal" but only for dxdiag...it will not affect games that use d3d ?
Or should i reinstall dx8.1 to get the best performance?...btw i use the reference drivers from 3dfx as i found the FV4.6 is not helping me

It`s the lonelines that`s the killer...

Edited by - NeoRAGERx on 12/01/2005 20:29:11
Go to Top of Page

avengerx
Novice

Brazil


23 Posts

Posted - 02/02/2005 :  19:05:09  Show Profile  Visit avengerx's Homepage  Send avengerx an ICQ Message  Click to see avengerx's MSN Messenger address  Reply with Quote
I think that using 3dfx ref drivers would help you less than fv2 drivers. d3d games will still work on dx9 although you can't use dxdiag to see if d3d is working. I am -not- sure, but I think that if a game requires dx8.1 or older, it will work fine even if you have dx9 installed. the problem could raise if you play a game that uses dx9 functions. In other words, downgrading to dx8.1 will not change things other than being able to see that spinning cube on dxdiag's test.

also, seems that 3dfx ref drivers support only ~dx6... fv2 goes up to dx8.1.
Go to Top of Page

Sanek
Novice

Canada
48 Posts

Posted - 04/02/2005 :  01:34:50  Show Profile  Visit Sanek's Homepage  Send Sanek an AOL message  Send Sanek an ICQ Message  Click to see Sanek's MSN Messenger address  Send Sanek a Yahoo! Message  Reply with Quote
I had the same problem.

How I fixed it:
-Completely uninstalled voodoo2 drivers (including the 2 services)
There is a guide (I think even maybe on this site) on how to remove voodoo2 completely, not just D3D portion of it.

-Installed older drivers (3dfx-released)

-Updated drivers to 3dfxzone.it 4.0 Gold Edition

Intel Celeron 433 MHz
128MB + 32MB RAM
40GB + 5.5GB HDD
ATI Rage IIc (poor D3D and OpenGL performance)
Dimond Monster 3D II 8MB 3D-Accelerator
Win98SE
Win2K Pro SP4 + Aston Shell 1.9.0
RedHat Linux 7.5
DirectX 8.1 (Win98)
FastVoodoo2 4.6 Driver Set
DirectX 9.0b (Win2K)
FastVoodoo2 4.0XP GE Driver Set
Go to Top of Page

bolognesi
Novice

Peru
3 Posts

Posted - 18/02/2005 :  05:33:03  Show Profile  Visit bolognesi's Homepage  Reply with Quote
hi i ha ve problem with directx 9.0 it say that i need to update my card driver and i did but still apperring the same advise i have a pentium III 64 mb ati rage iic plzz help me
Go to Top of Page

Nightbird
Moderator



1938 Posts

Posted - 21/02/2005 :  20:43:27  Show Profile  Visit Nightbird's Homepage  Send Nightbird a Yahoo! Message  Reply with Quote
What's your gfx card ??

______________________________________________

In-ter-ac-tive :
The way video games were always meant to be played
______________________________________________

Welcome to 3dfxzone.it Community
_____________________________
Go to Top of Page

bolognesi
Novice

Peru
3 Posts

Posted - 23/02/2005 :  17:10:57  Show Profile  Visit bolognesi's Homepage  Reply with Quote
i have a ATI RAGE IIC 64 MB i already update my card driver with w82474e this the last version of this driver card my computer work with windows 98 my computer have the minimus requited that a need to play the sims 2 Procesador Intel(R) Pentium(R)III a 600 MHz
256 MB de RAM
but i see that my graphip card doesnt appered on the list if my graphic card doesnt appered the game couldnt work???
Go to Top of Page
Page: of 2 Previous Topic Topic Next Topic  
Next Page

 New Topic  Reply to Topic
 Print topic
Jump To:

 

Forum Rules

Legal Info

Privacy

Contact Us

3dfxzone.it

HWSetup.it

ForumZone.it

 

All trademarks used are properties of their respective owners - Forum Graphics and Contents 2001 - 2014 3dfxzone.it - Forum Engine Snitz Forums