3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home | Profile | Register | Active Topics | Members | Search | Search with Google | FAQ | 3dfxzone.it
Username:
Password:
Save Password
Forgot your Password?

 Index
 3dfx Hardware & Software
 General Discussions
 MesaFX
 New Topic  Reply to Topic
 Print topic

Previous Page | Next Page
Author Previous Topic Topic Next Topic
Page: of 55

dborca
Average

Romania


425 Posts

Posted - 23/07/2004 :  11:23:52  Show Profile  Visit dborca's Homepage  Send dborca a Yahoo! Message  Reply with Quote
New DLL (small update on my situ): fixed a bug in glBitmap.

Regards,
Daniel Borca

Edited by - dborca on 23/07/2004 11:25:49
Go to Top of Page

agrelaphon
Average

Greece


164 Posts

Posted - 03/08/2004 :  15:27:12  Show Profile  Visit agrelaphon's Homepage  Reply with Quote
Hi to all
Fired up my voodoo3 yesterday and downloaded mesafx rc(dated 23-7-04) and I get this


instead of this (with mesafx6.1.8)


I tested MOHAA and it runs OK. So why is NWN all painted up???

"Love and peace brothers"
Go to Top of Page

dborca
Average

Romania


425 Posts

Posted - 03/08/2004 :  19:09:32  Show Profile  Visit dborca's Homepage  Send dborca a Yahoo! Message  Reply with Quote
my bad. i screwed up the automatic mipmap generation in latest rc. i know that for several days, but been too busy to upload the fix.

Regards,
Daniel Borca
Go to Top of Page

omega_supreme
Average

Netherlands


149 Posts

Posted - 10/08/2004 :  21:12:31  Show Profile  Reply with Quote
dborca, i while ago i was testing with Doom 3 alpha. Maybe you can remember. Now that the full game is out I gave it a try but i will not load anymore. The error message is "could not load opengl" I dont think you can do anything with that but does the full version use a newer opengl version than the alpha (that worked good with mesafx)?
Unfortunately theres no demo, but what do you think about it?
Go to Top of Page

dborca
Average

Romania


425 Posts

Posted - 11/08/2004 :  12:32:55  Show Profile  Visit dborca's Homepage  Send dborca a Yahoo! Message  Reply with Quote
i know doom3 retail doesn't work. i do have the error log, and it seems the application gets stuck somewhere in ChoosePixelFormat. which is piece of cake, but i am /really/ busy these days. besides the mesa CVS was down. i'll try to "guess" what is the problem and i'll try to publish a new release or rc (which also fixes the aforementioned automatic mipmap generation).

Regards,
Daniel Borca
Go to Top of Page

dborca
Average

Romania


425 Posts

Posted - 11/08/2004 :  12:32:55  Show Profile  Visit dborca's Homepage  Send dborca a Yahoo! Message  Reply with Quote
i know doom3 retail doesn't work. i do have the error log, and it seems the application gets stuck somewhere in ChoosePixelFormat. which is piece of cake, but i am /really/ busy these days. besides the mesa CVS was down. i'll try to "guess" what is the problem and i'll try to publish a new release or rc (which also fixes the aforementioned automatic mipmap generation).

Regards,
Daniel Borca
Go to Top of Page

omega_supreme
Average

Netherlands


149 Posts

Posted - 11/08/2004 :  17:13:17  Show Profile  Reply with Quote
Your the greatest
Go to Top of Page

milen
Novice

25 Posts

Posted - 12/08/2004 :  09:32:25  Show Profile  Visit milen's Homepage  Reply with Quote
Dborca is it possible to make option for forcing specific pixel format no matter what application wants.
Go to Top of Page

ggab
Average

Argentina


294 Posts

Posted - 13/08/2004 :  10:25:23  Show Profile  Visit ggab's Homepage  Send ggab an ICQ Message  Click to see ggab's MSN Messenger address  Reply with Quote
quote:
Originally posted by milen

Dborca is it possible to make option for forcing specific pixel format no matter what application wants.



Mesafxev.txt in 6.1.08...maybe this environment variables can help....


MESA_FX_IGNORE_PIXEXT
	OS: all
	HW: Napalm
	Desc: force 565 16bpp mode (traditional Voodoo, no 32/15bpp)
MESA_FX_IGNORE_TEXFMT
	OS: all
	HW: Napalm
	Desc: disable 32bit textures
MESA_FX_IGNORE_CMBEXT
	OS: all
	HW: Napalm
	Desc: disable Napalm combiners (color/alpha/texture)
	Note: this option allows dual-TMU cards perform single-pass
	      trilinear, but some advanced (multi)texturing modes
	      won't work (GL_EXT_texture_env_combine)
Go to Top of Page

dborca
Average

Romania


425 Posts

Posted - 13/08/2004 :  12:51:50  Show Profile  Visit dborca's Homepage  Send dborca a Yahoo! Message  Reply with Quote
@milen
Right now, it should work that way (forcing to whatever the underlying hw can handle).

I fixed the Doom3 startup error. It used to fail because Doom3 requested STEREO visual! Doh...
Anyways, the DLL was online since yesterday, but noone cared enough to take a look at my situ. Hehe.

BUT, Doom3 seemed to be more picky than I thought:
quote:

---- R_InitOpenGL -----
Initializing OpenGL subsystem
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
...calling CDS: ok
...created window @ 0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...attempting to use stereo
...PIXELFORMAT 6 selected
...creating GL context: succeeded
...making context current: succeeded

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
------------------------------------
sound: STEREO
...using GL_ARB_multitexture
X..GL_ARB_texture_env_combine not found
X..GL_ARB_texture_cube_map not found
X..GL_ARB_texture_env_dot3 not found
...using GL_ARB_texture_env_add
X..GL_ARB_texture_non_power_of_two not found
...using GL_ARB_texture_compression
X..GL_EXT_texture_filter_anisotropic not found
...using GL_EXT_texture_lod
...using GL_1.4_texture_lod_bias
...using GL_EXT_shared_texture_palette
...using GL_EXT_texture3D
...using GL_EXT_stencil_wrap
X..GL_NV_register_combiners not found
X..GL_EXT_stencil_two_side not found
X..GL_ATI_separate_stencil not found
X..GL_ATI_fragment_shader not found
...using GL_ARB_vertex_buffer_object
...using GL_ARB_vertex_program
X..GL_ARB_fragment_program not found
********************
ERROR: The current video card / driver combination does not support the necessary features
********************



These are really bad...
X..GL_ARB_texture_cube_map not found
X..GL_ARB_texture_env_dot3 not found
X..GL_ARB_fragment_program not found

I'm trying to tweak values a bit, but don't expect too much! I'm working blindly and receiving error logs from a friend.

Regards,
Daniel Borca
Go to Top of Page

omega_supreme
Average

Netherlands


149 Posts

Posted - 13/08/2004 :  15:53:40  Show Profile  Reply with Quote
quote:

I fixed the Doom3 startup error. It used to fail because Doom3 requested STEREO visual! Doh...
Anyways, the DLL was online since yesterday, but noone cared enough to take a look at my situ. Hehe.



Strange a cannot find the new dll on your page
Where is it located i would like to try it out.

or is this the one Im lookin for

MesaFX 6.1.0.9 win32 DLL (release candidate 10)
Go to Top of Page

Nightbird
Moderator



1939 Posts

Posted - 14/08/2004 :  10:14:47  Show Profile  Visit Nightbird's Homepage  Send Nightbird a Yahoo! Message  Reply with Quote
quote:
or is this the one Im lookin for
MesaFX 6.1.0.9 win32 DLL (release candidate 10)

The RC 10 is from the 23 jul 2004.
But the file online is really the "last" version (12 aug. 2004).

______________________________________________

In-ter-ac-tive :
The way video games were always meant to be played
______________________________________________

Welcome to 3dfxzone.it Community
_____________________________
Go to Top of Page

Voodoo5
Average

Canada
157 Posts

Posted - 15/08/2004 :  17:33:32  Show Profile  Visit Voodoo5's Homepage  Reply with Quote
Doom 3 will not start for me using the latest Mesa .dll, I have posted the error log below in case it can help in some way:

1835 MHz AMD CPU with MMX & 3DNow! & SSE
512 MB System Memory
64 MB Video Memory
Winsock Initialized
Hostname: voodoo
IP:
doom using MMX & SSE for SIMD processing
enabled Flush-To-Zero mode
------ Initializing File System ------
Current search path:
D:\Program Files\Doom 3/base
D:\Program Files\Doom 3\base\pak004.pk4 (5137 files)
D:\Program Files\Doom 3\base\pak003.pk4 (4676 files)
D:\Program Files\Doom 3\base\pak002.pk4 (6120 files)
D:\Program Files\Doom 3\base\pak001.pk4 (8972 files)
D:\Program Files\Doom 3\base\pak000.pk4 (2698 files)
D:\Program Files\Doom 3\base\game00.pk4 (2 files)
game DLL: 0x0 in pak: 0x0
file system initialized.
--------------------------------------
----- Initializing Decls -----
------------------------------
------- Initializing renderSystem --------
using ARB renderSystem
renderSystem initialized.
--------------------------------------
4966 strings read from strings/english.lang
Couldn't open journal files
execing editor.cfg
execing default.cfg
couldn't exec DoomConfig.cfg
couldn't exec autoexec.cfg
4966 strings read from strings/english.lang
----- Initializing Sound System ------
sound system initialized.
--------------------------------------
----- R_InitOpenGL -----
Initializing OpenGL subsystem
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
...calling CDS: ok
...created window @ 0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...attempting to use stereo
...PIXELFORMAT 6 selected
...creating GL context: succeeded
...making context current: succeeded

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
------------------------------------
sound: STEREO
...using GL_ARB_multitexture
X..GL_ARB_texture_env_combine not found
X..GL_ARB_texture_cube_map not found
X..GL_ARB_texture_env_dot3 not found
...using GL_ARB_texture_env_add
X..GL_ARB_texture_non_power_of_two not found
...using GL_ARB_texture_compression
X..GL_EXT_texture_filter_anisotropic not found
...using GL_EXT_texture_lod
...using GL_1.4_texture_lod_bias
...using GL_EXT_shared_texture_palette
...using GL_EXT_texture3D
...using GL_EXT_stencil_wrap
X..GL_NV_register_combiners not found
X..GL_EXT_stencil_two_side not found
X..GL_ATI_separate_stencil not found
X..GL_ATI_fragment_shader not found
...using GL_ARB_vertex_buffer_object
...using GL_ARB_vertex_program
X..GL_ARB_fragment_program not found
********************
ERROR: The current video card / driver combination does not support the necessary features
********************
Error during initialization
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL

Edited by - Voodoo5 on 15/08/2004 17:40:56
Go to Top of Page

mcmagostini
Initiate

Brazil


64 Posts

Posted - 17/08/2004 :  08:06:44  Show Profile  Visit mcmagostini's Homepage  Send mcmagostini an ICQ Message  Click to see mcmagostini's MSN Messenger address  Reply with Quote
Got issues playing Serious Sam First Encounter with MesaFX.

* Playing with Rainbow's OGL addon i get some issues on the texture
edges and i can see light sources through walls, beside that the
flare effect doesn't work as it should. It doesn't show evrytime
i'm looking at the sun for example, only at some angles.
But the game map show correctly.

* Playing with MesaFX (tried various versions) i get all the above
issues solved, but the game map gets corrupted. I also noticed a
performance drop with MesaFX compared to Rainbow's OGL addon

In time: Everytime i start the game either in Mesafx or in Rainbow's
OGL, I can't leave the game and enter it again in the other OGL mode.
I always have to restar my PC to be able to play on each mode.
This doesn't happen if I try on Quake3, which used to let me play
whatever mode without a reboot, just a dll ranaming.

Here are the screenshots showing the game map:

MesaFX:

67.4 KB

Rainbow's:

73.95 KB

AmigaMerlin / SFFT / MesaFX
Sempron64 3000+, 512MB DDR400 2,5-3-3-11
Voodoo5 5500 PCI (Rev 3100)
ASUS K8N4-E
Go to Top of Page

ps47
Skilled

Slovakia
1463 Posts

Posted - 18/08/2004 :  21:54:53  Show Profile  Visit ps47's Homepage  Send ps47 an AOL message  Send ps47 an ICQ Message  Reply with Quote
finally I have found out what was causing all the trouble with hitman2,hitman contracts and freedom fighters when running on a voodoo3 with mesafx.seems like the hitman engine thinks (when running with mesafx) that the voodoo3 IS DXT capable (and voodoo3 cant do DXT,right?),the engine automatically enables DXT compression and boom the game goes down with graphic errors and crashes.

so,if you want to run those games on a voodoo3,make sure you have following line in the *.ini file before starting the game with mesafx:
DisableDXT 1
all games should run ok,all you have to enable is sw rescaling,no need to mess with texusUMA

The 3Dfx Helppage and Game Guide / Voodoo3/4/5 enviromental variables

Edited by - ps47 on 18/08/2004 22:02:18
Go to Top of Page
Page: of 55 Previous Topic Topic Next Topic  
Previous Page | Next Page

 New Topic  Reply to Topic
 Print topic
Jump To:

 

Forum Rules

Legal Info

Privacy

Contact Us

3dfxzone.it

HWSetup.it

ForumZone.it

 

All trademarks used are properties of their respective owners - Forum Graphics and Contents 2001 - 2017 3dfxzone.it - Forum Engine Snitz Forums