3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home | Profile | Register | Active Topics | Members | Search | GoogleSearch | FAQ | 3dfxzone.it
Username:
Password:
Save Password
Forgot your Password?

 Index
 Software Platforms and Apps
 3D-Analyze and TnL games
 Call of Duty 2
 New Topic  Reply to Topic
 Print topic

Author Previous Topic Topic Next Topic  

Zaxeiler
Novice

USA
7 Posts

Posted - 28/07/2009 :  04:51:54  Show Profile  Visit Zaxeiler's Homepage  Reply with Quote
I have the Intel GMA 950 integrated video card. My computer has a 2.16 GHz Intel Core 2 Duo processor, and 2 GBs of RAM running Windows XP Pro. I am trying to run Call of Duty 2.

According to the system requirements lab: http://www.systemrequirementslab.com/referrer/srtest

My video card, lacks the capability to produce Video HW Transform & Lighting and Vertex Shader v 1.1

This seems like two very easy things to fix with 3D-Analyze (I'm using v2.36b). However, when trying to start the game up, I cannot get past the screen that says I've suffered an unrecoverable dx error. I've searched these forums before posting this message and someone suggested that "force 16-bit zbuffer (w/stencil)" be checked. When I do that, I get this error: "Couldn't create a 640x480 depth stencil surface: invalid call"

I've also read that I should simply go into the game, and change the settings to make it run in dx7. I have no problem with this, except I can't even get into the game's menus to change that, I can't get the game to load at all.

Any suggestions would be greatly appreciated.

Rolo01
Experienced

Germany


508 Posts

Posted - 28/07/2009 :  11:19:29  Show Profile  Visit Rolo01's Homepage  Reply with Quote
You could try Swiftshader to run the game :
http://vogons.zetafleet.com/viewtopic.php?t=18230&highlight=swiftshader
Go to Top of Page

ps47
Moderator

Slovakia
1461 Posts

Posted - 28/07/2009 :  11:19:43  Show Profile  Visit ps47's Homepage  Send ps47 an AOL message  Send ps47 an ICQ Message  Reply with Quote
dx7 mode will activate automatically when your card is not dx9 capable..basically,the game is trying to tell you do yourself a favor and spend $50 on ebay on a real graphics card..

The 3Dfx Helppage and Game Guide / Voodoo3/4/5 enviromental variables
Go to Top of Page

Zaxeiler
Novice

USA
7 Posts

Posted - 29/07/2009 :  07:29:38  Show Profile  Visit Zaxeiler's Homepage  Reply with Quote
quote:
Originally posted by ps47

dx7 mode will activate automatically when your card is not dx9 capable..basically,the game is trying to tell you do yourself a favor and spend $50 on ebay on a real graphics card..



I don't know what kind of admin writes back a reply like that... I obviously stated that I'm trying to run the game on a school laptop and not a full out gaming rig... It's not that I couldn't just buy a new card, but if I could run it on 3D Analyze on this computer, it would be nice to play in class or just around.

On a side note, Rolo, thanks for trying to help, I'll look into the link you wrote down...
Go to Top of Page

Zaxeiler
Novice

USA
7 Posts

Posted - 29/07/2009 :  08:13:08  Show Profile  Visit Zaxeiler's Homepage  Reply with Quote
quote:
Originally posted by Rolo01

You could try Swiftshader to run the game :
http://vogons.zetafleet.com/viewtopic.php?t=18230&highlight=swiftshader



Ok, so I've tried that. It still doesn't quite work, although, I'm definitely one step closer with Swiftshader.

The game will now load up, splash screen, intro movies, and the main menu. However, when the main menu (or what to me, since it's my "first time" is the profile selection screen) loads up, everything looks fine, but my mouse icon won't move off of the left screen boarder. I can move up and down, just not off of that border.

Any thoughts?
Go to Top of Page

Zaxeiler
Novice

USA
7 Posts

Posted - 29/07/2009 :  08:29:41  Show Profile  Visit Zaxeiler's Homepage  Reply with Quote
quote:
Originally posted by Rolo01

You could try Swiftshader to run the game :
http://vogons.zetafleet.com/viewtopic.php?t=18230&highlight=swiftshader



Well, actually, turns out forcing "windowed mode" frees up the mouse, and I can set it to take up the full screen windowed... However, now when in game, the textures are wrong, and some things aren't being shown or drawn out correctly. I think Swiftshader fixes the pixel issues and lets the game run, but the vid card I have is still missing T&L. I guess I'll try to combine the features of Swiftshader with 3D-analyze to try and emulate everything I need. Only problem is, when you run 3D-analyze, it deletes the .dll files for Swiftshader, so I need to copy them in manually, making it hard to decide what I need.

Thanks again for your help, any other thoughts would definitely be appreciated.
Go to Top of Page

ps47
Moderator

Slovakia
1461 Posts

Posted - 29/07/2009 :  18:11:13  Show Profile  Visit ps47's Homepage  Send ps47 an AOL message  Send ps47 an ICQ Message  Reply with Quote
try running the game with swiftshader (this basically emulates a graphics card using your cpu),set it to run in the dx7 mode,switch back to your normal graphics card with 3danalyze and try to run it.with a bit of luck,you will be able to fool the game to run on your graphics card with the correct settings (dx7)..and have you tried updating your graphics drivers? it could help a LOT,estecially if you are using some outdated version..


btw,you did not mention you are running a laptop in your first post.

The 3Dfx Helppage and Game Guide / Voodoo3/4/5 enviromental variables

Edited by - ps47 on 29/07/2009 18:14:37
Go to Top of Page

Zaxeiler
Novice

USA
7 Posts

Posted - 31/07/2009 :  02:22:41  Show Profile  Visit Zaxeiler's Homepage  Reply with Quote
quote:
Originally posted by ps47

try running the game with swiftshader (this basically emulates a graphics card using your cpu),set it to run in the dx7 mode,switch back to your normal graphics card with 3danalyze and try to run it.with a bit of luck,you will be able to fool the game to run on your graphics card with the correct settings (dx7)..and have you tried updating your graphics drivers? it could help a LOT,estecially if you are using some outdated version..


btw,you did not mention you are running a laptop in your first post.



Yeah, my drivers are up to date. Actually, it turns that part of the problem would be solved with an old set of drivers, which would tell the game I had more capabilities, but I am up to date. I'm trying that type of combination right now, the game won't run period without Swiftshader, so I have to keep that .dll in the game's folder. And I'm trying to add specific ones from 3D-Analyze to cover the other things I need.

Anyone have any thoughts on specifically what things should be checked for CoD:2 in 3D-Analyze?

Finally, I know I realized that I hadn't specifically said I was on a school laptop. But do know, I was only frustrated because it seems that anyone that posts on this forum is obviously looking for a workaround to a new graphics card, so that seemed like the last piece of advice that would be useful.

Thanks to all for help, post any other helpful thoughts and I keep posting how it's going.
Go to Top of Page

Nightbird
Moderator



1938 Posts

Posted - 02/08/2009 :  19:26:46  Show Profile  Visit Nightbird's Homepage  Send Nightbird a Yahoo! Message  Reply with Quote
About the mouse and SW,
Try to edit the file Swiftshader.ini with KeepSystemCursor=0

______________________________________________

In-ter-ac-tive :
The way video games were always meant to be played
______________________________________________

Welcome to 3dfxzone.it Community
_____________________________
Go to Top of Page

Tomas
Novice

2 Posts

Posted - 26/08/2009 :  13:49:34  Show Profile  Visit Tomas's Homepage  Reply with Quote
quote:
Originally posted by ps47

try running the game with swiftshader (this basically emulates a graphics card using your cpu),set it to run in the dx7 mode,switch back to your normal graphics card with 3danalyze and try to run it.with a bit of luck,you will be able to fool the game to run on your graphics card with the correct settings (dx7)..and have you tried updating your graphics drivers? it could help a LOT,estecially if you are using some outdated version..


btw,you did not mention you are running a laptop in your first post.



hi, i have the same issue as thread starter and i reached the point where the game starts up using only swiftshader but i hope to increase its performance using also 3danalyze (atm its like 5fps or so, insanely slow..).

my problem is that:
1- when i start 3danalyze it deletes the swifts. dlls and i have no clue how to make them cooperate together
2- using 3danalyze according to http://www.3dfxzone.it/enboard/topic.asp?TOPIC_ID=7198 gives me fatal dx errors that i didnt manage to overcome with any 3danalyze settings

my work notebook (i cannot change its HW features): compaq nc6220, cpu 1,7ghz, 1,5gb ram, onboard gmintel, xp sp2, dx9c

thanks in advance for any helpful suggestions
Go to Top of Page

Tomas
Novice

2 Posts

Posted - 14/10/2009 :  14:18:27  Show Profile  Visit Tomas's Homepage  Reply with Quote
quote:
Originally posted by Tomas

quote:
Originally posted by ps47

try running the game with swiftshader (this basically emulates a graphics card using your cpu),set it to run in the dx7 mode,switch back to your normal graphics card with 3danalyze and try to run it.with a bit of luck,you will be able to fool the game to run on your graphics card with the correct settings (dx7)..and have you tried updating your graphics drivers? it could help a LOT,estecially if you are using some outdated version..


btw,you did not mention you are running a laptop in your first post.



hi, i have the same issue as thread starter and i reached the point where the game starts up using only swiftshader but i hope to increase its performance using also 3danalyze (atm its like 5fps or so, insanely slow..).

my problem is that:
1- when i start 3danalyze it deletes the swifts. dlls and i have no clue how to make them cooperate together
2- using 3danalyze according to http://www.3dfxzone.it/enboard/topic.asp?TOPIC_ID=7198 gives me fatal dx errors that i didnt manage to overcome with any 3danalyze settings

my work notebook (i cannot change its HW features): compaq nc6220, cpu 1,7ghz, 1,5gb ram, onboard gmintel, xp sp2, dx9c

thanks in advance for any helpful suggestions



ANYBODY HELP PLEASE?
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Print topic
Jump To:

 

Forum Rules

Legal Info

Privacy

Contact Us

3dfxzone.it

HWSetup.it

ForumZone.it

 

All trademarks used are properties of their respective owners - Forum Graphics and Contents 2001 - 2014 3dfxzone.it - Forum Engine Snitz Forums