3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home | Profile | Register | Active Topics | Members | Search | Search with Google | FAQ | 3dfxzone.it
Username:
Password:
Save Password
Forgot your Password?

 Index
 3dfx Hardware & Software
 Voodoo4/5 Setup and tweaking
 SFFT alpha drivers - V3/4/5 - Join to Testing
 New Topic  Reply to Topic
 Print topic

Previous Page | Next Page
Author  Topic Next Topic
Page: of 123

agrelaphon
Average

Greece


164 Posts

Posted - 26/06/2004 :  21:50:10  Show Profile  Visit agrelaphon's Homepage  Reply with Quote
quote:
Hi,
I've tested Alpha7 and seems to have problem using it jointly with mesa 6.x. ( 6.1.0.8) When I use games like NWN and Call Of duty black screen come out in NWN and screen crash when change the detail of texture in Call af duty.
All went ok when I switched back to Amigamerlin 3.0; No crash and NWN works ok.
Seems that many user that use your Alpha release have the same problem
Can you give a look at this problem ?



Maybe that is caused by the older glide3x.dll file (3dfx original) that is included in the drivers. Amigamerlin3.0 uses newer glide3x, glide2x files.
Go to Top of Page

SuperFurryFurryThing
Average

386 Posts

Posted - 27/06/2004 :  01:09:28  Show Profile  Visit SuperFurryFurryThing's Homepage  Reply with Quote
The intention was to ship the Glide dll's from Amigerlin 3. These drivers only address DirectX issues. I would suggest that if you are having problems with OpenGl/Glide based games, that you try using the Glide dll's supplied with Amigerlin 3. It is possible that I have shipped the wrong glide dll at some point.

SFFT
Go to Top of Page

mcmagostini
Initiate

Brazil


64 Posts

Posted - 27/06/2004 :  03:02:42  Show Profile  Visit mcmagostini's Homepage  Send mcmagostini an ICQ Message  Click to see mcmagostini's MSN Messenger address  Reply with Quote
The glide dll's supplied with SFFT alpha7 are exactly the same ones
that comes with the AM3.0. There must be another reason, then.

I was playing an adventure mouse pointing game called Syberia and the
sequel Syberia II... on Syberia II i had issues with AM 3.0 drivers
that were adressed by SFFT. The problems were on the animations mainly
and on the video cuts that didnt play smoothly. They even hang.
With SFFT the problems were gone.

I have a question though. Is that normal to be very few options in
3dfxtools when using SFFT drivers? Besides that there's no longer
the video overlay gamma settings. Asking this just to be sure.

3dfxSalutes,
Matheus

AmigaMerlin / SFFT / MesaFX
Sempron64 3000+, 512MB DDR400 2,5-3-3-11
Voodoo5 5500 PCI (Rev 3100)
ASUS K8N4-E

Edited by - mcmagostini on 27/06/2004 03:04:31
Go to Top of Page

FBS
Initiate

Canada
80 Posts

Posted - 27/06/2004 :  04:29:17  Show Profile  Visit FBS's Homepage  Reply with Quote
SFFT just want to let you know to forget about my mouse problems. I found a problem in my mouse cable.
Go to Top of Page

Garth
Novice

Argentina
33 Posts

Posted - 27/06/2004 :  05:18:25  Show Profile  Visit Garth's Homepage  Reply with Quote
quote:
Originally posted by Nightbird

quote:
C&C Generals stopped working with these drivers

Not sure that Garth is speaking C&C Generals since this game needs a difficult workaround and without being sure of the result...
Perhaps he's speaking about C&C Renegade ?



No, no. Im talking about C&C Generals, I followed all the steps (except for the ones that ask for AM 2.5 SE to be installed ) and ran the game and it doesn't work.

CF
Go to Top of Page

Amigamerlin
Average

Italy


163 Posts

Posted - 27/06/2004 :  08:01:28  Show Profile  Visit Amigamerlin's Homepage  Reply with Quote
quote:
Originally posted by SuperFurryFurryThing

The intention was to ship the Glide dll's from Amigerlin 3. These drivers only address DirectX issues.


I know, but this 2 games maybe use d3d for calling something in opengl.
I really don't know but is really strange: NWN come out with a black screen aftere the mený and Call of Duty Freeze after trying to change the detail or resolution and the most important thing is that THIS 2 Games have the same problem whichever glide3x I use.

I've tested 4 Glide3x (old and new) and all mesa Release from 6.1.0.3 but with noone this games start and are stable.

As I said no problem when returning back to AM 3.0 and I've tested the same 2 games with the same Glide3x without problem.

I hope all is clear.

Again As I said seems that only the user that are using Alpha driver have this problem !!

SFFT, please try Call of Duty and NWN (Demo). Maybe in this 2 games D3D routine are called to open screen or for doing something in the games mený.

Please give it a try and let me know.

Amigamerlin
3DFXZONE MODERATOR
Powerd By Voodoo5 6000

Edited by - Amigamerlin on 27/06/2004 08:05:20
Go to Top of Page

Nightbird
Moderator



1939 Posts

Posted - 27/06/2004 :  08:37:21  Show Profile  Visit Nightbird's Homepage  Send Nightbird a Yahoo! Message  Reply with Quote
quote:
Im talking about C&C Generals, I followed all the steps (except for the ones that ask for AM 2.5 SE to be installed ) and ran the game and it doesn't work

So, did the game work before that you use the SFFT drivers ?

______________________________________________

In-ter-ac-tive :
The way video games were always meant to be played
______________________________________________

Welcome to 3dfxzone.it Community
_____________________________
Go to Top of Page

gab
Novice

8 Posts

Posted - 27/06/2004 :  09:44:05  Show Profile  Visit gab's Homepage  Reply with Quote
quote:
Originally posted by ggab

playing in opengl (mesafx) the 1964 emu hangs and then i press the reset buttom, when winXP restarts display:


another, i tried with 1964 emu & jabo 1.51 d3d plugin and i get the blue screen with this info:
3dfxvs.dll - Address bf9e900e base at bf9b7000, Datestamp 40cf6ab5



well, with the new alpha7 & v3, it has the same problem. Windows Blue screen and "3dfxvs.dll - Address bf9eXXXX base at bf9b7000, Datestamp 4xxxxxxx" where x, is in hexadecimal (change in a random way).

I also tested: replacing the 3dfxvs.dll & 3dfxvsm.sys from AS3.0 (AmigaSport) driver with SSFT's ones, and crashed too (the same way).
but maybe i'm doing something wrong... i really think that the drivers should work in the right way, almost perfect, i guess. (confused )
Go to Top of Page

SuperFurryFurryThing
Average

386 Posts

Posted - 27/06/2004 :  12:46:48  Show Profile  Visit SuperFurryFurryThing's Homepage  Reply with Quote
As too the Gamma Ramp / Tools options I have been adding some code from Amigerlin 3, which shou;ld add these features to the next version. There is a still a rebooting problem with these drivers. I am looking at this next. I have a fair idea where the problem is so it should be fixable.

SFFT
Go to Top of Page

Garth
Novice

Argentina
33 Posts

Posted - 27/06/2004 :  16:52:42  Show Profile  Visit Garth's Homepage  Reply with Quote
quote:
Originally posted by Nightbird

quote:
Im talking about C&C Generals, I followed all the steps (except for the ones that ask for AM 2.5 SE to be installed ) and ran the game and it doesn't work

So, did the game work before that you use the SFFT drivers ?



Yes, well....partially, i got it to run with missions and everything but i didn't have any textures, and i couldn't see the units

CF
Go to Top of Page

Nightbird
Moderator



1939 Posts

Posted - 27/06/2004 :  17:46:00  Show Profile  Visit Nightbird's Homepage  Send Nightbird a Yahoo! Message  Reply with Quote
quote:
Yes, well....partially, i got it to run with missions and everything but i didn't have any textures, and i couldn't see the units

I see...
And when the game "worked", you were using what driver ? the 2.5SE or the 3.0 ??

______________________________________________

In-ter-ac-tive :
The way video games were always meant to be played
______________________________________________

Welcome to 3dfxzone.it Community
_____________________________
Go to Top of Page

Garth
Novice

Argentina
33 Posts

Posted - 28/06/2004 :  00:06:43  Show Profile  Visit Garth's Homepage  Reply with Quote
2.5 SE because i couldn't get it to work under 3.0

CF
Go to Top of Page

zandro
Novice

Norway
7 Posts

Posted - 28/06/2004 :  09:56:29  Show Profile  Visit zandro's Homepage  Reply with Quote
quote:
Zandro how well does this demo work with Amigerlin 3


it works ok with AM 3.0 but the speed is ofcourse "hamperd"
by the fact that the d3d part of older drivers (AM 3.0" no pun intended)
is rather bad compared to sffa7. But i have tried other d3d games with big improvments
i both speed an image quality. amongst these are "serious sam second encounter"
that was impossible to run in d3d because of strange artifacts, black squares
where textures where suppose to be and, realy bad rendering speed... but no longer
since i went over to sff alpha 7 :) going to test a lot of games and compare
with older drivers

Edited by - zandro on 28/06/2004 10:02:58
Go to Top of Page

Garth
Novice

Argentina
33 Posts

Posted - 28/06/2004 :  22:36:42  Show Profile  Visit Garth's Homepage  Reply with Quote
hegemonia works fine with 3da under Win xp and no other tweaks

CF
Go to Top of Page

SuperFurryFurryThing
Average

386 Posts

Posted - 01/07/2004 :  00:45:40  Show Profile  Visit SuperFurryFurryThing's Homepage  Reply with Quote
I have sent the next driver version to Glide and Amigermerlin, so we should see it soon hopefully. This fixes at least one rebooting problem.

SFFT
Go to Top of Page
Page: of 123  Topic Next Topic  
Previous Page | Next Page

 New Topic  Reply to Topic
 Print topic
Jump To:

 

Forum Rules

Legal Info

Privacy

Contact Us

3dfxzone.it

HWSetup.it

ForumZone.it

 

All trademarks used are properties of their respective owners - Forum Graphics and Contents © 2001 - 2017 3dfxzone.it - Forum Engine © Snitz Forums