3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home  ~  Profile  ~  Register  ~  Active Topics  ~  Members  ~  Search  ~  FAQ  ~  3dfxzone.it
Save Password
Forgot your Password?

 Software Platforms and Apps
 Windows and Software for Windows
 Windows 98SE, Voodoo2, and Geforce256
 New Topic  Reply to Topic
 Print topic

Author Previous Topic Topic Next Topic  


5 Posts

Posted - 16/03/2011 :  17:11:02  Show Profile  Visit rooket's Homepage  Reply with Quote
Hi I need some help. I've been tinkering with a Pentium III 1.0Ghz machine and whenever I run the 3DFX installation files, it gives me an error. Let's start with the system specifications as follows:

430W Antec PSU which apparantly is supplying the -5V rail since the system does power on fine and installs O/S fine.
Intel Pentium III Coppermine 1.0Ghz CPU
Asus CUSL2-C i815e Intel Chipset Motherboard
512Mb (2x 256Mb) RAM
Asus v6600 Deluxe AGP graphics @ 3.3V default motherboard setting
Diamond Monster 3D II 12Mb PCI 3DFX Voodoo2 graphics card
SB Live! Value PCI
Promise/Maxtor SATA II Controller Card
Maxtor 160GB SATA II HDD
No onboard sound, no onboard modem, no onboard LAN

Ok so if I install the AGP graphics card drivers, they work after rebooting and then I install the latest Diamond Monster 3D II drivers and get an error about COMCTL32.DLL. It says that the driver currently installed in Windows is newer than the one trying to install. So I tell it to not overwrite (if I tell it to overwrite the file, it does nothing anyway and just forces me to say no to overwriting).

After installing the Diamond Monster 3D II drivers, I can't access the display properties any more and if I run a 3DFX game, the system freezes.

I remember having this problem years ago when trying to set this up and I remember having to mess with memory addressing and IRQ values. I tried changing the memory address in safe mode according to the official 3DFX S3 fix documentation, but the PC started to have more issues after that so it needs to be changed back I guess. People on IRC (yes I know that place is not helpful) told me that the AGP card does not have an IRQ value because it is a video card, but that is false because it is actually using IRQ 11. When you boot up the machine it says it is on IRQ 11 and within control panel system properties it shows that it is using IRQ 11. That should be fine. I don't believe that the Voodoo II card is using an IRQ but I very well could be wrong since it is a multimedia device in a PCI slot and usually those share IRQs between a couple slots on these boards.

Anyway any help would be appreciated. I'd discuss the other system that I tried this same setup in, but that would just confuse this thread and I want to keep that entirely separate. I want to focus on this Pentium III for now and it is supplying the proper voltage to the AGP slot.

Would anyone suggest that I just stick a PCI graphics card in there instead of the AGP and that would solve the problem? I'm going to try to find one. I was hoping to use the Geforce256 for Direct3D and the Voodoo2 for glide, 3dfx games mainly dos based stuff.


5 Posts

Posted - 17/03/2011 :  17:37:44  Show Profile  Visit rooket's Homepage  Reply with Quote
Ok I fixed it and here is what I did:

(Oh yeah I already had DirectX 7 installed from my AGP Geforce256 V6600 Asus driver CD and I already had the intel chipset drivers for the motherboard installed within Win98SE)

Important: Make sure that DirectX is installed before installing these drivers.

1.) Used regedit.exe and did a search for the word "Monster", then deleted all Diamond Monster 3D II registry entries.
2.) Uncompressed 3dfxzone.it's Voodoo2 reference drivers to C:\3DFX (this can be any directory name really)
3.) Used 3dfxzone.it's Voodoo2 reference driver installation text and followed its instructions as to where to find and delete the Monster 3D II *.inf file from the Windows folder.
4.) Removed the Monster 3D II from device manager.
5.) Restarted the PC and let it find the Voodoo2 card.
6.) Told it to browse to C:\3DFX and the subfolder for the driver within.
7.) It installed the driver and booted into windows then prompted to reboot, so I rebooted.
8.) Booted back into Windows and verified that the Voodoo2 1000 tab was installed in display properties.
9.) Tested a couple games: Tomb Raider II set to Voodoo graphics in settings and Shipwrekers demo from CD.

Everything seems to work fine. I found one Voodoo1 game locks up the PC but maybe it isn't compatible with Voodoo2 cards. I think most games will work.

So right now I have two 3DFX Voodoo2 cards in this machine and a home made SLI cable. Tomb Raider II apparantly won't display in 1024x768 non-SLI so I guess everything works.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Print topic
Jump To:


Forum Rules

Legal Info


Contact Us

Search with Google





All trademarks used are properties of their respective owners - Forum Graphics and Contents © 2001 - 2019 3dfxzone.it - Forum Engine © Snitz Forums