Driver "development" with modern aspect ratios

Started by Dolenc, 23 May 2022, 18:57:53

Previous topic - Next topic

Obi-Wan Kenobi

QuoteOriginally posted by Dolenc

Please restrain yourself from further ****posting.

Not everything will be to your liking, and thats just fine ;)
No swearing in this forum if I like something -->  I'll say it
If I dislike something I will happily say it, it's called having an honest opinion, it's part of the Free Speech system here in the EU ;)

Be mindful of your thoughts, think first before you say something bad to people you don't even know.
There is no need to cuss people out all because someone does not agree with your so called experimental projects

In the end, it's the choices you make that determine your outcome...
Just relax and enjoy what you do best.
Powered By The Force, x-3dfx & The Jedi Academy


There are 2 problems currently with v1.0 (ofc theres more, but this 2 bother me)

- Sometimes it will lock-up on game start, kinda big problem ;). I fixed it once, clearly not. Could be related just to my system configuration, still...
- Switching between windowed and fullscreen will eventually cause a crash

It will have to wait a couple of weeks, have to do some other stuff first, but think I have an idea whats going on, fixes will go in v1.1.

If someone tests the driver and you have issues, write it here and add what gpu and cpu was used.

Well time management at its finest... For the first issue, good news I found where it happens. Bad news, where it happens, mesa.
Second issues fixed, need to be more careful porting newnew glide stuff. Also added back sse2 texture download stuff(partial) that I blamed for the first issue.

Think the first issue is resolved too. Had to build mesafx with the glide lib of the actual glide.dll that Im using. You learn something new everyday.

Ill wait till tomorrow, to test some more, if Im not prematurly celebrating, but I think this is it.

Also alt-tab issue crashing the game got resolved during the proces. It still wont minimize the game, but it also wont crash it anymore.

Looks stable as it should be now.
Some more testing and if confirmed, Ill upload the v1.1


3dfx Wide driver v1.1
(link expires in 30 days)

Supports vsa-based cards, no v3, for win98.
Extract, read readme.txt - Extra notes, run setup.exe.

Version 1.1
- Fixed occasional lock-up on game start
- Added back sse2 texture downloads, that were removed from v1.0
- Fixed eventual crash from switching between windowed and fullscreen in glide
- Alt-tab wont crash openGl games anymore


I am sorry for my English ;) :D


In thanks, you get some screenshots

So atleast I didnt break the screenshot function.
Game does run a bit too slow, causes lots of tearing.

And unreal-ated, but still some.
For ease of searching patches for games and troubleshooting, a good the best source is You can find windescreen info, which graphics and sound api the game supports, inputs, troubleshooting. Really good place, where I always check first. You get used to their design and lots of info provided at first sight.

Some more patches I use:

Quake2 Unofficial v3.24 Patch, adds some more settings, resolutions and music, so cd doesnt have to be use.

Quake 3 palleted textures and hor+ patch

Half-life, for won version, adds music, additional resolutions (oh the warp screens!)

Fakk2 fov patch, resolution in autoexec.cfg same as any quake3 engine game

Unreal tournament (for free fps set detailed textures to false in game preferences for glide)

For more, you know where to look.


Since someone asked, where are the glide sources.

Sourceforges latest development glide version, that Sezero pushes forward.
This one is nice, since you can peek at the history of commits.
Sourceforge, last release is 30303

To get development branch use CVS

cvs -d -z6 co -P -r glide-devel-branch Glide3
(note: use Glide3 with capital G -- that will get both glide3x and swlibs)

To get an older version, if you need it
CVS Get date
cvs -d -z6 co -D "2007-02-15" -P -r glide-devel-branch Glide3


QuoteOriginally posted by Dolenc
- Fixed occasional lock-up on game start

I still got lockups occasionally on game start.
What it turned out to be the problem is Agp aperture size, I had it at 256mb, so set that to 32mb, v5 has no agp texturing anyway, no more problems for the last 2 weeks.

One game that doesnt work, that I tried, is Sin. It works with 6.3 mesaFx, You can use that mesafx version, just put in the game folder and if you want to use a different resolution, use glide override, it will force it(also patch the game ofc).

I have "future plans" to use newer mesa, but in 6.3+ they changed some things and glide part needs some rework, so somedayTM.

More rune in action


Hi Dolenc, all,

thank you a lot for yours effort and contribution.

QuoteOriginally posted by Dolenc

3dfx Wide driver v1.0
(link expires in 15 days, @Glide please, put it somewhere and edit the post)

Now both 1.0 and 1.1 versions of Wide Driver are physically hosted by 3dfxzone and downloadable from these following URLs.

Enjoy your day


Hi Glide,
I tried the links but they don't work.
I did however find the drivers in the dedicated section:


but the download does not start.
Please can you check?

Thank you.:)
I am sorry for my English ;) :D


Think you 2 deserve a couple of screenshots

Heretic II v1.07



QuoteOriginally posted by ciacara

Hi Glide,
I tried the links but they don't work.
I did however find the drivers in the dedicated section:


but the download does not start.
Please can you check?

Thank you.:)

Hi ciacara,

I'm sorry for inconvenient and many thanks for your message. Now both links have been fixed.

On these screenshots, Heretic II, one of the best, once again :).

Bye bye


Added glide to github, so all changes will be documented.
Same plan for other parts of the driver or anything 3dfx related I will do, slowly...


Setting a virtual machine for driver compile

Theres plenty of way how to approach this, this is one of them.

I use a virtual machine (VirtualBox) running WinXp sp3 to compile 3dfx stuff. Benefits being, still using an older OS to avoid compatibility issues, but still working on a new(er) machine, with its higher resolution, multiple monitors, network access, very easy to install software, mount .iso-s and just generally fast. And if you "botch" something in the OS, you just clone a clean, already setup instance and continue.

Used this for all glide versions so far and minivdd driver. For MesaFx I tend to use win10.

1. Oracles VirtualBox can be downloaded ->here<-. Your system has to have virtualization support and enabled in bios, usually by default.
Download and install.

2. Create a new virtual machine
Enter a name for it, select a folder where the virtual HDD and settings will go, select a WinXp 32bit version. Next...

2.1 Set memory size this system can use, I tend to give 4096MB. Next...

2.2 Create a virtual hdd, leave default settings, vid, Dynamically allocated, 10GB is fine.

Virtual instance is created.

3. Start it, browse to your winXp.iso image, from which you will install the OS, Start...

3.1 WindowsXp installation will commence! Go through the install procedure, same as on actual hardware.
Create a partition from that 10GB and format it to ntfs.

After a minute or so and a few restarts, were in! Configure whatever needs configuring (language, date/time) from inside the od. Sound should be working, inputs should be fine, resolution should be a small window.

4. Now the fun part... Configuring it for ease of life.

From the MenuBar go to Devices / Insert Guest Additions CD image...

This will mount some extra utility cd, that contains additional drivers and utilities. It will help with window scaling, sharing folders, usb drivers and so on... Must install.
It will either autoplay or if it doesnt, go to my computer and run the installation disc. 

After the restart, we can now rescale the window or go fullscreen and it will dynamically adjust.
You can see an aditional oracle icon next to the clock.

4.1 From the MenuBar go to Devices / Shared Clipboard and set it to Bidirectional. Do the same for Drag and Drop. This will enable shared "copy paste" between you host machine and the guest virtual one.

4.2 On your host pc, create a folder, you will use for sharing data between host and guest machine. I have it like "F:\Virtualka\SharedFolder"

From the MenuBar select Devices / Shared Folders / Shared Folders Settings

Click on the plus folder icon, set path to your shared folder and check Auto-mount and Make Permanent

Save/ok. Now if you check under My Computer. You will see the newly attached network folder. Convinient way to share files between systems.

4.3 For installing from .iso images aka mounting virtual cds.
From MenuBar, select Devices /Optical Drives / Choose a disk file...

Select the .iso from the host machine. It will be mounted as a "disk drive" in the virtual guest system.

This is the easiest way to install software needed from .iso-s. But before you go ham installing... Do one more thing.

4.4 Install common software
- 7zip
- Notepad++
- Whatever you need for every system

5. Make a copy of your clean virtual machine, before you start installing SDK-s.
Close the running virtual machine, MenuBar File/ Close /save the machine state

From the VirtualBox Manager window, right click on your clean installation and Clone it. Name it FreshInstall or something, so you dont forget which one to always start with.

So when (not if) you **** up your installation, you always have a clean one, ready to clone again and go!

Thats it... Fast, safe, easy to restore



Hi Dolenc, and all,

thank you a lot to have shared this, very useful, tutorial.

Have fun.

Bye bye