mesafx with glide to use with voodoo3, how?

Started by vade, 04 May 2006, 10:46:01

Previous topic - Next topic



My intention is to set up my voodoo3 3000 to function in linux in a way that i can play opengl games hw accelerated. (ie ustunts )

To accomplish this i assume i need to compile glide2x and mesafx

But how is this done?

I downloaded glide3x from sourceforge but I only made it to compile by making a lot modifications to make files some .c files and to Probably some functionlity was lost due to this..
After that i read from somewhere net that voodoo3 and mesafx need glide2x to work, so i'm back at the starting point.

Is it true that voodoo3 % mesafx combination works only with glide2x?
If yes, Where can i get glide2x for linux? I could not find it from anywhere.

What's the story with libSage?
I tried to just link my game against it but it gave me few unresolved symbols.. I also tried to just modify LD_xx env variable like instructed but the game did not take library in use..

It seems to be quite difficult to live with voodoo board and linux nowadays..



Try to contact Daniel Borca. He is (was) a mesa developer, so he will be able to help you for sure. His site is . Look there for contact information.


I tried to contact Daniel but get no reply. :(

I guess th problem is just finding Mesa version (enough old) which will compile against my precompiled glide libraries.(either glide3 or glide2)

Someone must have a mesa version lying in somewhere which is enough old.
I searched the Mesa web site but I think all versions there are too new!?

Anyone, could you please give some pointers where to find such a mesa..?