3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home | Profile | Register | Active Topics | Members | Search | GoogleSearch | FAQ | 3dfxzone.it
Username:
Password:
Save Password
Forgot your Password?

 Index
 3dfx Hardware & Software
 Voodoo4/5 Setup and tweaking
 V5 6000 overclocking software fix needed
 New Topic  Reply to Topic
 Print topic

Next Page
Author Previous Topic Topic Next Topic
Page: of 2

hanksemenec
Initiate

USA


71 Posts

Posted - 18/03/2004 :  15:20:09  Show Profile  Visit hanksemenec's Homepage  Reply with Quote
Currently both VControl and VooDoo5 Overclocker set the frequency only on the first VSA100. I checked this with SoftIce.

So if you are trying to overclock, the card will still run rest of the chips at factory settings. You wil see only a marginal improvement in speed, since the card will run as fast as it's slowest VSA100.

Let me know if anyone has time to look at this.

Hank

NitroX infinity
Average

Netherlands
352 Posts

Posted - 18/03/2004 :  16:08:17  Show Profile  Visit NitroX infinity's Homepage  Reply with Quote
This sounds like music to my ears and produces a big grin on my face :D

Does this also apply to the V5 5500?

Edited by - NitroX infinity on 18/03/2004 16:09:23
Go to Top of Page

Rolo01
Experienced

Germany


508 Posts

Posted - 18/03/2004 :  19:56:45  Show Profile  Visit Rolo01's Homepage  Reply with Quote
This explains perfectly why I didnt get any improvement when overclocking the 6000. And I thought she still isnt maxed out on a P4-2800...
Go to Top of Page

Amigamerlin
Moderator

Italy


163 Posts

Posted - 19/03/2004 :  17:01:04  Show Profile  Visit Amigamerlin's Homepage  Reply with Quote
quote:
Originally posted by hanksemenec

Currently both VControl and VooDoo5 Overclocker set the frequency only on the first VSA100. I checked this with SoftIce.

So if you are trying to overclock, the card will still run rest of the chips at factory settings. You wil see only a marginal improvement in speed, since the card will run as fast as it's slowest VSA100.

Let me know if anyone has time to look at this.

Hank



Ciao Hank
Vcontrol come from koolsmoky and I think he can fix it.
I'll FWD this request to him and obviously I'll keep you informed about.

Ciao

Amigamerlin
3DFXZONE MODERATOR
Powerd By Voodoo5 6000
Go to Top of Page

amp_man
Experienced

545 Posts

Posted - 21/03/2004 :  03:51:49  Show Profile  Visit amp_man's Homepage  Reply with Quote
Two questions:

Does this also apply to the V5 5500/5000

Is this also the case with adjusting the registry value (grxclk or some such thing)?
Go to Top of Page

beta
Novice

24 Posts

Posted - 21/03/2004 :  16:24:22  Show Profile  Visit beta's Homepage  Reply with Quote
This does apply to Voodoo5, changing tghe value of "Grxclock" only OC's one of the VSA-100's, this makes a difference to FSAA performance but under normal operation does not effect framerate. In order to OC a Voodoo5 you need to hack the BIOS "pllCtrl1" register and reflash to give the desired core/memory clock speed for both VSA-100's. This does work.

-Edit: After further testing I'm convinced that flashing the BIOS won't do it either. The second VSA-100 and it's 32MB of SDRAM (The SLI slave) doesn't seem to have it's speed set by the firmware or software, it seems to locked at 166MHz, which is obviously the stock hardware clock output. The BIOS must be solely for the SLI master chip. SLI must be enabled in software, (drivers). In other words when you're booting up, in safe mode, DOS etc, SLI is not functioning.

Edited by - beta on 26/03/2004 00:26:00
Go to Top of Page

raffa
Novice

20 Posts

Posted - 26/03/2004 :  16:04:21  Show Profile  Visit raffa's Homepage  Reply with Quote
interesting topic!

this explains perfectly why a soft overclock doesnt show up in fillrate gain like expected, while a bios overclock does.

beta, i can't confirm the edit part of your message. i have the bios modded to 178 mhz, that gives me a multitexturing fillrate of 630 mTexels in 3dmark2000. i "underclocked" back to stock 166mhz with vcontrol and got 585 mTexels.
take this as 100% and do a quick calculation, voila 108% of clock gives 108% fillrate.
if i overclock via vcontrol up to 190mhz i get 635mTexels, same as with everything else higher or equal than 181mhz, maybe my bios settings are 181mhz, dont remember excactly.

a thought: why would they use an extra PLL for the secondary VSA100 and the other half of ram? i see no reason to do so.


edit: checked my bios, it clocks to 178,9mhz so i dont know why the fillrate improves till 181mhz

Edited by - raffa on 26/03/2004 16:09:20
Go to Top of Page

beta
Novice

24 Posts

Posted - 27/03/2004 :  02:41:24  Show Profile  Visit beta's Homepage  Reply with Quote
quote:
this explains perfectly why a soft overclock doesnt show up in fillrate gain like expected, while a bios overclock does.


Thats sort of what I though initially...

quote:
beta, i can't confirm the edit part of your message. i have the bios modded to 178 mhz, that gives me a multitexturing fillrate of 630 mTexels in 3dmark2000. i "underclocked" back to stock 166mhz with vcontrol and got 585 mTexels.
take this as 100% and do a quick calculation, voila 108% of clock gives 108% fillrate.
if i overclock via vcontrol up to 190mhz i get 635mTexels, same as with everything else higher or equal than 181mhz, maybe my bios settings are 181mhz, dont remember excactly.


Have you tried Quake3 benchmarking? See if you get the same sort of result. Direct3D is a different subsystem and SLI AA is handled differently when using this API.

quote:
a thought: why would they use an extra PLL for the secondary VSA100 and the other half of ram? i see no reason to do so.


Due to it being effectively another "card" rendering alternate scanlines, this device and it's memory is only actually used when Direct3D or Glide are initialised the rest of the time it is idle.

quote:
edit: checked my bios, it clocks to 178,9mhz so i dont know why the fillrate improves till 181mhz



eh? it's late...

-Edit: wow it must have been...

Anyway with a pllCtrl1 of aprox 182.8 the card shows a definate SLI mode fps gain, at 182.5: lower fps than at 166??!

Edited by - beta on 01/04/2004 21:47:51
Go to Top of Page

koolsmoky
Moderator

101 Posts

Posted - 02/04/2004 :  21:45:06  Show Profile  Visit koolsmoky's Homepage  Reply with Quote
I've already sent a vsa100 oc tool to Hank. Sit tight and wait for the results.

-KoolSmoky
Go to Top of Page

cosworth6k
Novice

Italy


27 Posts

Posted - 03/04/2004 :  14:02:29  Show Profile  Visit cosworth6k's Homepage  Send cosworth6k an ICQ Message  Reply with Quote
quote:
Originally posted by koolsmoky

I've already sent a vsa100 oc tool to Hank. Sit tight and wait for the results.

-KoolSmoky





Image Insert:

732 Bytes

3dfx ZoNe moderator
Powered by voodoo 6000
Go to Top of Page

koolsmoky
Moderator

101 Posts

Posted - 03/04/2004 :  14:21:07  Show Profile  Visit koolsmoky's Homepage  Reply with Quote
Glide has kindly put the VSA100 OC tool up for downloads.
Grab it here: http://www.3dfxzone.it/news/puntatore.php?uid=261
Besure to read the docs before using it.

Thanks for bringing this to light Hank!

Enjoy!
KoolSmoky

Edited by - koolsmoky on 03/04/2004 14:26:44
Go to Top of Page

raffa
Novice

20 Posts

Posted - 03/04/2004 :  16:17:17  Show Profile  Visit raffa's Homepage  Reply with Quote
that was fast, thx koolsmoky!

tool is working fine on my 5500 :D
Go to Top of Page

hanksemenec
Initiate

USA


71 Posts

Posted - 03/04/2004 :  16:52:09  Show Profile  Visit hanksemenec's Homepage  Reply with Quote
Wow,

Thank you very much. The tool works like a charm. All 4 chips on V5 6k are getting programmed :).

Thank You,

Hank
Go to Top of Page

beta
Novice

24 Posts

Posted - 03/04/2004 :  19:34:38  Show Profile  Visit beta's Homepage  Reply with Quote
quote:
Originally posted by koolsmoky

I've already sent a vsa100 oc tool to Hank. Sit tight and wait for the results.

-KoolSmoky



I, and quite a few other posting in this topic, Would be interested to know how this was achieved? Unrevealing binaries disclose nothing of course...
Go to Top of Page

lecram25
Average

USA
327 Posts

Posted - 04/04/2004 :  02:39:37  Show Profile  Visit lecram25's Homepage  Reply with Quote
Like you're gonna get the source, lol

| AMD Athlon XP (Barton) 2800+ @ 3200+ (11x200) | Cooler Master Jet 7 | ABIT NF7-S Rev 2.0 (nForce 2) | Corsair TWINX1024-3200C2 | Sapphire ATi Radeon 9500np>9700np | Sound Blaster Live! X-Gamer 5.1 | 3dfx VoodooTV 200 PCI | Western Digital 40GB & 120GB HDD | Pioneer 106s DVD | LG 52x24x52 CDRW | Cambridge Soundworks Desktop Theater 5.1 DTT3500 Digital Speakers |
Go to Top of Page

amp_man
Experienced

545 Posts

Posted - 04/04/2004 :  03:25:25  Show Profile  Visit amp_man's Homepage  Reply with Quote
quote:
Originally posted by lecram25

Like you're gonna get the source, lol



I don't think beta is looking for the exact source, just to know how kool got it working, like what registry values it changes or something. And seeing how this really is a community, sharing such information shouldn't really be that big of a deal, it would benefit all.
Go to Top of Page
Page: of 2 Previous Topic Topic Next Topic  
Next Page

 New Topic  Reply to Topic
 Print topic
Jump To:

 

Forum Rules

Legal Info

Privacy

Contact Us

3dfxzone.it

HWSetup.it

ForumZone.it

 

All trademarks used are properties of their respective owners - Forum Graphics and Contents 2001 - 2014 3dfxzone.it - Forum Engine Snitz Forums