3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home | Profile | Register | Active Topics | Members | Search | GoogleSearch | FAQ | 3dfxzone.it
Username:
Password:
Save Password
Forgot your Password?

 Index
 3dfx Hardware & Software
 General Discussions
 No mouse in MesaFX?
 New Topic  Reply to Topic
 Print topic

Author Previous Topic Topic Next Topic  

Sanek
Novice

Canada
48 Posts

Posted - 13/03/2004 :  23:18:27  Show Profile  Visit Sanek's Homepage  Send Sanek an AOL message  Send Sanek an ICQ Message  Click to see Sanek's MSN Messenger address  Send Sanek a Yahoo! Message  Reply with Quote
:( I have no mouse cursor, when using mesafx opengl32.dll

Any1 knows y?


my specs:
Intel Celeron 433 MHz
32MB+128MB RAM
40GB+2GB+5.5GB HDD
ATI Rage II (Actually its RAGE II based, it doesn't have 3D support)
Dimond Monster 3D II 8MB 3D-Accelerator
Win2k Server
DirectX 9.0b
FastVoodoo2 4.0GE Driver Set

Intel Celeron 433 MHz
128MB + 32MB RAM
40GB + 5.5GB HDD
ATI Rage IIc (poor D3D and OpenGL performance)
Dimond Monster 3D II 8MB 3D-Accelerator
Win98SE
Win2K Pro SP4 + Aston Shell 1.9.0
RedHat Linux 7.5
DirectX 8.1 (Win98)
FastVoodoo2 4.6 Driver Set
DirectX 9.0b (Win2K)
FastVoodoo2 4.0XP GE Driver Set

amp_man
Experienced

545 Posts

Posted - 14/03/2004 :  00:23:39  Show Profile  Visit amp_man's Homepage  Reply with Quote
you need to turn hardware mouse off, I think. Is this the latest MesaFX, and under what game?
Go to Top of Page

Sanek
Novice

Canada
48 Posts

Posted - 14/03/2004 :  01:30:06  Show Profile  Visit Sanek's Homepage  Send Sanek an AOL message  Send Sanek an ICQ Message  Click to see Sanek's MSN Messenger address  Send Sanek a Yahoo! Message  Reply with Quote
I'm trying to run mesafx for Counter-Strike 1.6.

I've tried doing this: set "Enable HardwareMouse=0", doesn't seem to work.

Anyway, I don't like mesa much, WickedGL was working for me great before I updated to the new drivers (Installed DX9 and V2 4.0 GE).

Now, if I use WGL, all I see is black screen with smthing on the right(attached image). Glide told me to reinstall V2 4.0 GE drivers, but I don't see how it may help - regular 3dfx glide works fine, mesa works too (no mouse though). Now, since it is very risky to uninstall DX9, I have to use regular drivers for CS1.5 and mesafx for CS1.6, since regular glide doesn't work there.

Heres my previous post, it explains the problem better:
http://www.3dfxzone.it/enboard/topic.asp?TOPIC_ID=951

WickedGL 3.02(FULL) Sceen:
Image Insert:

29.72 KB

Intel Celeron 433 MHz
128MB + 32MB RAM
40GB + 5.5GB HDD
ATI Rage IIc (poor D3D and OpenGL performance)
Dimond Monster 3D II 8MB 3D-Accelerator
Win98SE
Win2K Pro SP4 + Aston Shell 1.9.0
RedHat Linux 7.5
DirectX 8.1 (Win98)
FastVoodoo2 4.6 Driver Set
DirectX 9.0b (Win2K)
FastVoodoo2 4.0XP GE Driver Set
Go to Top of Page

Sanek
Novice

Canada
48 Posts

Posted - 14/03/2004 :  02:56:19  Show Profile  Visit Sanek's Homepage  Send Sanek an AOL message  Send Sanek an ICQ Message  Click to see Sanek's MSN Messenger address  Send Sanek a Yahoo! Message  Reply with Quote
Ok, I've determined why WickedGL doesn't work - 4.0 GE drivers do something bad :(

Just to check, I've tried 3.5 XP driver set and WickedGL worked great! When I put back 4.0 GE Drivers, WGL stopped working again.

I guess I'm gonna have to stick with 3.5 XP drivers.

Intel Celeron 433 MHz
128MB + 32MB RAM
40GB + 5.5GB HDD
ATI Rage IIc (poor D3D and OpenGL performance)
Dimond Monster 3D II 8MB 3D-Accelerator
Win98SE
Win2K Pro SP4 + Aston Shell 1.9.0
RedHat Linux 7.5
DirectX 8.1 (Win98)
FastVoodoo2 4.6 Driver Set
DirectX 9.0b (Win2K)
FastVoodoo2 4.0XP GE Driver Set

Edited by - Sanek on 14/03/2004 02:58:46
Go to Top of Page

amp_man
Experienced

545 Posts

Posted - 14/03/2004 :  04:58:29  Show Profile  Visit amp_man's Homepage  Reply with Quote
Possibly your download of the FastVoodoo 2 4.0 drivers is bad, try downloading them again. Also, did you recieve any errors when you installed the drivers?
Go to Top of Page

Sanek
Novice

Canada
48 Posts

Posted - 14/03/2004 :  23:48:31  Show Profile  Visit Sanek's Homepage  Send Sanek an AOL message  Send Sanek an ICQ Message  Click to see Sanek's MSN Messenger address  Send Sanek a Yahoo! Message  Reply with Quote
nah, the download was ok, I compared file sizes.

nope, no errors, while installing, but I did get a mipmap error, which I quickly corrected with the patch.

Intel Celeron 433 MHz
128MB + 32MB RAM
40GB + 5.5GB HDD
ATI Rage IIc (poor D3D and OpenGL performance)
Dimond Monster 3D II 8MB 3D-Accelerator
Win98SE
Win2K Pro SP4 + Aston Shell 1.9.0
RedHat Linux 7.5
DirectX 8.1 (Win98)
FastVoodoo2 4.6 Driver Set
DirectX 9.0b (Win2K)
FastVoodoo2 4.0XP GE Driver Set
Go to Top of Page

dborca
Average

Romania


425 Posts

Posted - 15/03/2004 :  10:02:41  Show Profile  Visit dborca's Homepage  Send dborca a Yahoo! Message  Reply with Quote
quote:
Originally posted by Sanek

I'm trying to run mesafx for Counter-Strike 1.6.

Is that all? The mouse, or you get some other errors?

Note that the mouse is part of the Windoze interface, which is not my best field.

You should try to ask help from Amigamerlin. He is able to compile Mesa now... and he does have more demos than I do.

Regards,
Daniel Borca
Go to Top of Page

raffa
Novice

20 Posts

Posted - 15/03/2004 :  16:48:26  Show Profile  Visit raffa's Homepage  Reply with Quote
hello there, i have no mouse in cs1.6, too.
well, not exactly no mouse, only the cursor is not visible in the menus - the mouse itself is working fine though.

but i'm on a voodoo 5, could be different?
Go to Top of Page

Sanek
Novice

Canada
48 Posts

Posted - 16/03/2004 :  16:43:35  Show Profile  Visit Sanek's Homepage  Send Sanek an AOL message  Send Sanek an ICQ Message  Click to see Sanek's MSN Messenger address  Send Sanek a Yahoo! Message  Reply with Quote
yep, same here, no mouse cursor

Intel Celeron 433 MHz
128MB + 32MB RAM
40GB + 5.5GB HDD
ATI Rage IIc (poor D3D and OpenGL performance)
Dimond Monster 3D II 8MB 3D-Accelerator
Win98SE
Win2K Pro SP4 + Aston Shell 1.9.0
RedHat Linux 7.5
DirectX 8.1 (Win98)
FastVoodoo2 4.6 Driver Set
DirectX 9.0b (Win2K)
FastVoodoo2 4.0XP GE Driver Set
Go to Top of Page

Victor
Novice

Russia
9 Posts

Posted - 19/03/2004 :  15:30:16  Show Profile  Visit Victor's Homepage  Reply with Quote
Try console command "vgui_emulatemouse 1". On Voodoo 5 5500 with MesaFX no mouse, but after type this command mouse appeared.
Go to Top of Page

Sanek
Novice

Canada
48 Posts

Posted - 19/03/2004 :  19:21:47  Show Profile  Visit Sanek's Homepage  Send Sanek an AOL message  Send Sanek an ICQ Message  Click to see Sanek's MSN Messenger address  Send Sanek a Yahoo! Message  Reply with Quote
ok, tnx, I will

Intel Celeron 433 MHz
128MB + 32MB RAM
40GB + 5.5GB HDD
ATI Rage IIc (poor D3D and OpenGL performance)
Dimond Monster 3D II 8MB 3D-Accelerator
Win98SE
Win2K Pro SP4 + Aston Shell 1.9.0
RedHat Linux 7.5
DirectX 8.1 (Win98)
FastVoodoo2 4.6 Driver Set
DirectX 9.0b (Win2K)
FastVoodoo2 4.0XP GE Driver Set
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Print topic
Jump To:

 

Forum Rules

Legal Info

Privacy

Contact Us

3dfxzone.it

HWSetup.it

ForumZone.it

 

All trademarks used are properties of their respective owners - Forum Graphics and Contents 2001 - 2014 3dfxzone.it - Forum Engine Snitz Forums