3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home | Profile | Register | Active Topics | Members | Search | GoogleSearch | FAQ | 3dfxzone.it
Username:
Password:
Save Password
Forgot your Password?

 Index
 3dfx Hardware & Software
 Voodoo3 and Velocity Discussions
 Weird Voodoo 3 3000 behaviour in D3D...
 New Topic  Reply to Topic
 Print topic

Author Previous Topic Topic Next Topic  

Huk
Novice

3 Posts

Posted - 02/10/2007 :  00:38:29  Show Profile  Visit Huk's Homepage  Reply with Quote
Hello to everyone.

I don't know what is going on - maybe that's the way it suppose to be? When I run game using Glide or OpenGL - everything is fine - but when I try some D3D games I can see A LOT of graphics corruption (or game don't won't to run at all) - good example is OperationFlashpoint (game support both Glide and D3D) - glide works perfectly, D3D practically doesn't work (all you can see is white... white something Smile ) - is this normal behavior? Maybe my motherboard is a problem? My PC is:

AMD Duron 1200
ECS K7VTA3B KT333 (VIA chipset)
384 MB Ram (DDR)
SB Live! 5.1 (sb0060)
Voodoo 3 3000 AGP/GeForce FX 5200/Geforce 2 mx 200/Riva TNT2 (right now - GeForce 5200)

Maybe some settings in my BIOS - when I tested Voodoo BIOS settings where like this:

AGP MODE 4X - is this important? Maybe setting this to 2X will help?
AGP Aparature Size 128 MB - from what I know - this doesn't make any diferences for Voodoo right?
AGP Driving Controll (AUTO)
AGP Master 1 WS Read/Write Disabled

Tested Games (D3D):

-Aliens Versus Predator (works perfectly)
-Carmageddon 2 Carpocalypse Now (works perfectly)
-Giants Citizen Kabuto (works perfectly)
-Mafia (works... with one of the drivers (not with AmigaSport 3.0) but quality is bad, with AmigaMerlin 3.0 most of the graphic is missing)
-OperationFlashpoint (in D3D most of the graphics is either missing or is white)
-Sonic Adventure DX (errors in menu, movies are white)
-Sonic Heroes (a lot of gfx errors when shadows are enabled)

phew... I write too much... :] last thing: I tried a lot of drivers (both latest official (under Windows 98se) and AmigaSport 3.0 - every one give me same errors (or almost the same).

P.S.

Sorry For my english Smile

Nightbird
Moderator



1938 Posts

Posted - 02/10/2007 :  00:59:16  Show Profile  Visit Nightbird's Homepage  Send Nightbird a Yahoo! Message  Reply with Quote
Since when do you get these graphics corruptions ?

______________________________________________

In-ter-ac-tive :
The way video games were always meant to be played
______________________________________________

Welcome to 3dfxzone.it Community
_____________________________
Go to Top of Page

Huk
Novice

3 Posts

Posted - 02/10/2007 :  06:27:05  Show Profile  Visit Huk's Homepage  Reply with Quote
quote:
Originally posted by Nightbird

Since when do you get these graphics corruptions ?



Well I bought three Voodoo 3 3000 cards 2 weeks ago - I put two of them in my PC and tested (one was damaged :( ) - there was no "since when" because I never used any Voodoo on this PC earlier - I bought Voodoo 3 3000 because with my old PC (Abit ZM6, Celeron 400 mhz) I had Voodoo 3 2000 and it worked great.

Again - sorry for my English :)
Go to Top of Page

ps47
Moderator

Slovakia
1461 Posts

Posted - 02/10/2007 :  22:10:26  Show Profile  Visit ps47's Homepage  Send ps47 an AOL message  Send ps47 an ICQ Message  Reply with Quote
flashpoint-all voodoo cards should use glide.no need to use d3d.
sonic games-these are relatively new,and voodoo3 is not exactly a great performer in those.graphics errors are expected (updating to the latest SFFT driver may,or may not fix those).
mafia-should run ok with the latest (SFFT) drivers.

The 3Dfx Helppage and Game Guide / Voodoo3/4/5 enviromental variables
Go to Top of Page

Diwiak
Novice

11 Posts

Posted - 04/10/2007 :  21:06:34  Show Profile  Visit Diwiak's Homepage  Reply with Quote
Ive got similar problem, but D3D is absolutely not running :-(((
Go to Top of Page

agrelaphon
Average

Greece


164 Posts

Posted - 04/10/2007 :  21:24:35  Show Profile  Visit agrelaphon's Homepage  Reply with Quote
For Mafia: There is a specific in game graphics setting that should be changed from default to stop some textures from flashing. I don't remember as i don't have the game now , but i think it was wbuffer something.
Also, because V3 only supports up to 256x256 textures, in game maps are almost unreadable.
Go to Top of Page

Huk
Novice

3 Posts

Posted - 05/10/2007 :  01:55:51  Show Profile  Visit Huk's Homepage  Reply with Quote
Ok guys - I have put Voodoo in my PC and changed few things in BIOS (AGP to 1X, disabled fastwrite, set aparature size to 4MB), cleaned old drivers with driver cleaner and installed latest SFFT. After that I have tested some games once more and... well I'm a bit confused...

Operation Flashpoint - I know I *should* use Glide but... I have found out that after disabling "multi texturing" (when running game in D3D mode) white graphics is gone - now game is playable (but sure looks ugly :) )

About Sonic Adventure - from what I can see - this gfx errors are missing textures(and movies) - nothing more, also some textures are over-sized (scaling problem?):

[URL=http://img266.imageshack.us/my.php?image=sonicrs8.jpg][/URL]

I have also tested something older - I tried to emulate N64 with "JoboD3D6-1.5.2" graphic plugin - but there were many graphic errors (depending on game). This thing uses D3D 6 - so it should have worked (at least I think it should) - so either D3D driver for Voodoo 3 is broken or my Hardware don't like my Voodoo - I will test Max Payne 1 to confirm this (this game worked perfectly with my old PC (Voodoo 3 2000).

I have one more question - which driver is the best for SAGE_0.9.2 ?

P.S

Thanks for your support and sorry for my English :)
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Print topic
Jump To:

 

Forum Rules

Legal Info

Privacy

Contact Us

3dfxzone.it

HWSetup.it

ForumZone.it

 

All trademarks used are properties of their respective owners - Forum Graphics and Contents 2001 - 2014 3dfxzone.it - Forum Engine Snitz Forums