3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home | Profile | Register | Active Topics | Members | Search | GoogleSearch | FAQ | 3dfxzone.it
Username:
Password:
Save Password
Forgot your Password?

 Index
 3dfx Hardware & Software
 Voodoo4/5 Discussions
 Bad flicker in DirectDraw Games
 New Topic  Reply to Topic
 Print topic

Author Previous Topic Topic Next Topic  

johnlinford
Novice

7 Posts

Posted - 19/02/2003 :  21:24:28  Show Profile  Visit johnlinford's Homepage  Reply with Quote
Hello!
I've installed the amigamerlin drivers 2.5se on Windows XP, and all my DirectDraw games have terible flickers. For example, in Baldur's Gate (#1) the cursor and sprites flicker. I don't have this problem with the driver that comes with XP (the microsoft signed one), but that driver doesn't have glide support. The problem also goes away if I run dxdiag and disable hardware accelleration for DirectDraw, but then my games run SLOW. Detailed specs follow:

AMD-K62 500Mhz
Voodoo5 5500 PCI
256 MB Ram
Windows XP, service pack 1

Any help would be lovely!
~John C.

Hey amigamerlin! Thanks for making a glide/opengl driver for XP that ACTUALLY WORKS! I love your drivers!

Glide
Web Admin

Napoli


24413 Posts

Posted - 20/02/2003 :  02:25:02  Show Profile  Visit Glide's Homepage  Reply with Quote
Welcome to forum ...

Do you have install chipset mainboard driver?
If yes, try solving problem with DirectX 9 setup.

If you need, i'm here

Ciao ciao

3dfxzone.it | hwsetup.it | Register
Go to Top of Page

johnlinford
Novice

7 Posts

Posted - 20/02/2003 :  18:18:34  Show Profile  Visit johnlinford's Homepage  Reply with Quote
quote:
Welcome to forum ...

Thanks! I feel welcome.

quote:
Do you have install chipset mainboard driver?

Erm, I'm not sure. I probably haven't. How would I do that?

quote:
If yes, try solving problem with DirectX 9 setup.

Oops! I should have mentioned, I've tried dx8, dx8.1, and dx9.0 and they all have the same problem.

~John C.
Go to Top of Page

ROTOR
Novice

Cuba
32 Posts

Posted - 21/02/2003 :  16:34:43  Show Profile  Visit ROTOR's Homepage  Reply with Quote
Hello

I am ROTOR, if you have problems with games that uses Direct Draw you make the following thing:

Enable -> Mip_map Dithering.
Disable -> D3DGuardband Clipping.

If you use games that also use acceleration OpenGL like Baldur´s Gate II you also make the following thing:

Enable -> Mip_map Dithering.
Disable -> Glide Guardband Clipping.
Disable -> OpenGL Guardband Clipping.
Disable -> Hidden Surface Removal.
Disable -> OpenGL Z-Culling

I hope with this your problem is solved.
Go to Top of Page

johnlinford
Novice

7 Posts

Posted - 25/02/2003 :  21:23:51  Show Profile  Visit johnlinford's Homepage  Reply with Quote
Thanks ROTOR for the reply, but it didn't work. I spent some time with it yesterday, and nothing I change in the 3dfx control panel changes the flicker. The only way I have found yet is to disable harware accelleration entirely under the Display Properties box, or, to run dxdiag and disable hardware accelleration for Direct Draw. I DO NOT want to do this, since my games run S-L-O-W when I have no accelleration enabled. Please!! Someone!! Anyone!! Do you have any idea how I can fix this??

Again, my specs (so people don't have to hunt backwards through the thread):
AMD-K62 500Mhz
Voodoo5 5500 PCI
256 MB Ram
Windows XP, service pack 1
DirectX 9.0
Go to Top of Page

johnlinford
Novice

7 Posts

Posted - 05/03/2003 :  16:17:19  Show Profile  Visit johnlinford's Homepage  Reply with Quote
Whooopie! I've fixed it! Here's what I did:

1) Uninstall 3dfx tools.
2) Reboot.
3) Search HD and remove ANYTHING with 3dfx or voodoo in it.
4) Search registry and remove ANYTHING with 3dfx or voodoo in it.
5) Install 3dhq 1.09 Beta 10 Drivers for WindowsXP.
6) Reboot.
7) Open 3dfx underground tools and make the following changes to DirectX settings:
a) Enable tripple buffer
b) Force mip-map dithering
c) Enable vertical sync
d) Enable z-buffer optimization
e) Buffered frames: 1 pending

After I did ALL that, my games were AWESOME! Ya! Hope this helps some of you guys.

~John C.
Go to Top of Page

Amigamerlin
Moderator

Italy


163 Posts

Posted - 06/03/2003 :  07:59:04  Show Profile  Visit Amigamerlin's Homepage  Reply with Quote
quote:
Originally posted by johnlinford

Whooopie! I've fixed it! Here's what I did:

1) Uninstall 3dfx tools.
2) Reboot.
3) Search HD and remove ANYTHING with 3dfx or voodoo in it.
4) Search registry and remove ANYTHING with 3dfx or voodoo in it.
5) Install 3dhq 1.09 Beta 10 Drivers for WindowsXP.
6) Reboot.
7) Open 3dfx underground tools and make the following changes to DirectX settings:
a) Enable tripple buffer
b) Force mip-map dithering
c) Enable vertical sync
d) Enable z-buffer optimization
e) Buffered frames: 1 pending

After I did ALL that, my games were AWESOME! Ya! Hope this helps some of you guys.

~John C.



Hello, If this game works good with 3dhq beta 10 must work better with amigamerlin 2.5 se. D3d section of beta 10 have some nasty bug with 2xfssa and DX7 games (try with Max Payne and let me know).
I remember to al that D3D section is by Koolsmoky that is moderator in one of our section

When you install amigamerlin2.5 se make sure to have read carefully the installation procedure.

Bye

Amigamerlin
3DFXZONE MODERATOR
3DHQ BROOD MEMBER
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Print topic
Jump To:

 

Forum Rules

Legal Info

Privacy

Contact Us

3dfxzone.it

HWSetup.it

ForumZone.it

 

All trademarks used are properties of their respective owners - Forum Graphics and Contents © 2001 - 2014 3dfxzone.it - Forum Engine © Snitz Forums