3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home | Profile | Register | Active Topics | Members | Search | GoogleSearch | FAQ | 3dfxzone.it
Save Password
Forgot your Password?

 3dfx Hardware & Software
 Voodoo4/5 Setup and tweaking
 How to get Amiga Merlin 3.0 final to work in XP??
 New Topic  Reply to Topic
 Print topic

Author Previous Topic Topic Next Topic  


2 Posts

Posted - 17/11/2003 :  23:11:12  Show Profile  Visit Allegro's Homepage  Reply with Quote
Hi, I've downloaded the latest Amiga Merlin 3.0 files from your site and followed the instructions on your site (including deleting a registry entry)

I use Windows XP Professional with the latest updates (Windows Update)
Steps 1 to 3 on the instructions went OK (however i had to change to my old graphics card to get the image back,)

However, i experienced problems completing the final step..

First i found no isetup.exe but only "setup.exe" in the Amiga Merlin 3.0 directory.
Tried that but after a while got the error: "Error 1904. Module C:\Program Files\3dfx Interactive\3dfx Tools\Tools\AdvTweak.dll failed to register. HRESULT -2147418113. Contact your support personnel." (Also got the same error with Color.dll, TVOut.dll LCD.dll, Feature.dll)
Selecting "Retry"didn't work, only "Ignore" let install finish.. But because it failed to install or regoister those files the driver didn't work.. Tried the repair option also, same result..

Any way to get it to install? Is there a write protection or so on those files that i could switch of? Anything else i could do?

Files in the extracted Amiga Merlin 3.0 folder:

3dfx Tools.msi
Driver Setup.exe

folder "driver2k"




545 Posts

Posted - 19/11/2003 :  21:40:45  Show Profile  Visit amp_man's Homepage  Reply with Quote
well, I'm not sure what the instrustions say exactly, but I know that you have to remove a registry entry, then run the driver install.exe and reboot before you can run setup.exe.
Go to Top of Page

NitroX infinity

352 Posts

Posted - 20/11/2003 :  07:58:06  Show Profile  Visit NitroX infinity's Homepage  Reply with Quote
Try to download the drivers from another website. They might have gotten corrupt in the process of downloading.
Go to Top of Page


2 Posts

Posted - 06/05/2004 :  20:14:37  Show Profile  Visit LazerTag's Homepage  Reply with Quote
Sorry to bring up an old thread, but I am a new Amigamerlin 3.0 user and I am having the exact problem described above. Apparenlty the DLL's used for the tools cannot register themselves on my system. I tried to add them manually from a command prompt using Regsvr32.exe but get an error there that it cannot be regitered as well. So for me the tools will not install but the driver appears to work fine.

I've tried searching but cannot find if this problem has been fixed or even if anyone else other then me and the above user have the problem.

I did follow the instructions for installing.

1) remove any old 3DFX drivers (I did do this to remove my V2 boards and rebooted)
2) remove the noted registry entry and reboot
3) install the drivers using Driver Setup.exe and reboot
4) install the tools using setup.exe (this was a little point of confusion as everyone refers to running "isetep.exe" at this step, which does not exist in the 2 different downloads I have gotten.)

The only other thing I tried during this was a manual install of the drivers as recommended by the readme that cam with the installation. And then reboot, install tools (ignoring errors), reboot, then install tools again but select repair.

End up still not working.

Last thing noted was after the tools install my ATI startup control would quit responding to the system? No biggie I turned it off, but I wonder if these issues are related to multiple video card installation or an ATI specific card being installed? or Maybe it's because I have a PCI model V5 5500 card?

Any help or ideas would be great, Here are my specs

P4 2.4c HT 800Mhz FSB
Windows XP Pro SP1 (all the latest hotfixes and patches)
512MEG Dual Channel DDR PC3200
ATI 9600 Pro 128MEG & V5 5500 PCI
DirectX9b, Catalyst 4.4, Amigamerlin 3.0 XP
SoundMax Digital 5.1

I can provide other info as needed.

thanks for any help.
Go to Top of Page


2 Posts

Posted - 08/05/2004 :  04:13:54  Show Profile  Visit LazerTag's Homepage  Reply with Quote
Sorted this out tonight.

Apparently the VooDoo card must be the primary from the BIOS for the tools to install.
Go to Top of Page


1 Posts

Posted - 06/08/2004 :  05:42:04  Show Profile  Visit ParallaxTZ's Homepage  Reply with Quote
I have this same thing, but my PCI voodoo4 is my secondary card. Is there any way to set the setting with it as secondary?
Go to Top of Page



278 Posts

Posted - 06/08/2004 :  23:33:45  Show Profile  Visit bloodworm's Homepage  Reply with Quote
try making it primary just to install the tools and then after the tools install, revert back to secondary. it just may work.

Bloody Mess
Go to Top of Page



278 Posts

Posted - 06/08/2004 :  23:35:06  Show Profile  Visit bloodworm's Homepage  Reply with Quote
by the way, I don't think any 3d apps will run in the secondary card anyways...... so the tools are useless on the secondary card(s). Quake 3 engine maybe??

Bloody Mess
Go to Top of Page


4 Posts

Posted - 15/01/2006 :  15:27:49  Show Profile  Visit pkiff's Homepage  Reply with Quote
I ran into this error with Amigamerlin 3.1 R11 under XP, and found that the solution described worked correctly: make sure to disable any onboard video and assign the Voodoo card as your primary video card.

When installing the 3dfx Tools, I received the following error: "Error 1904. Module C:\Program Files\3dfx Interactive\3dfx Tools\Tools\AdvTweak.dll failed to register. HRESULT -2147418113. Contact your support personnel." just like the original poster.

In my case, I have a ThinkPad 600X laptop in a docking station using a Voodoo 5 5500 PCI and during the uninstall/install process of the new Amigamerlin drivers my laptop's built-in video somehow got re-enabled. The laptop video was not functioning, mind you, it was just sitting in the Device Manager with an exclamation mark indicating that it couldn't find enough resources. I know it had been disabled before, so I was surprised to find it with a yellow exlamation mark instead of disabled, and by disabling it manaually again, the 3dfx Tools were allowed to install correctly, as they should.

Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Print topic
Jump To:


Forum Rules

Legal Info


Contact Us





All trademarks used are properties of their respective owners - Forum Graphics and Contents 2001 - 2014 3dfxzone.it - Forum Engine Snitz Forums