3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home | Profile | Register | Active Topics | Members | Search | GoogleSearch | FAQ | 3dfxzone.it
Username:
Password:
Save Password
Forgot your Password?

 Index
 3dfx Hardware & Software
 Voodoo2 Setup and tweaking
 Is my Voodoo2 hooking D3D correctly?
 New Topic  Reply to Topic
 Print topic

Author Previous Topic Topic Next Topic  

toddfx
Novice

5 Posts

Posted - 26/03/2012 :  22:08:32  Show Profile  Visit toddfx's Homepage  Send toddfx an AOL message  Reply with Quote
Is the 3DFX splash screen logo supposed to appear when launching a DirectX game? My OpenGL & Glide capabilities are working fine (I get the 3DFX splash screen), but I never get it when launching any DirectX game.

I'm running SLI Orchid Righteous 12mb Voodoo2s under Windows 98 SE. I've tried every voodoo2 driver known to man and also several versions of DirectX, but am currently using DirectX 8.1b and FastVoodoo2 4.0 GE drivers. How can I be certain I am getting D3D voodoo acceleration?

I have of course tried FastVoodoo 4.6 but have the same results, and have read that 4.0 GE is worth a try in some cases. I tried DirectX 9.0c (latest working in Win98 to my knowledge), but it had no effect and in fact seemed to cause additional problems, so I stepped back down to 8.1b.

The dxdiag v7 and v8 tests both pass, however the cube spins extremely fast (probably about 10 revolutions as second). I've seen it before where it would spin much more slow.

On final note on a slightly different topic:
My 3DFX System Info screen is glitchy (overlapping text) and shows incorrect RAM ammounts on all drivers I tried (even FastVoodoo 4.6) except for 3DFX reference drivers version 3.02. When I have SLI enabled (and "Detected") and FastVoodoo drivers installed, 3DFX System Info claims I have 4MB frame buffer and 8 MB Texture. However when I have the 3DFX reference driver 3.02 installed, I get the full 8MB frame buffer and 16MB texture.

Thanks a ton guys!

Edited by - toddfx on 26/03/2012 22:15:11

toddfx
Novice

5 Posts

Posted - 27/03/2012 :  05:28:23  Show Profile  Visit toddfx's Homepage  Send toddfx an AOL message  Reply with Quote
Ok so i've kind of answered my own question about the splash screen appearing - I know how that it does NOT appear when running D3D.

I also learned that the System Info anomaly is actually just a UI glitch in all FastVoodoo drivers. Good to know.

HOWEVER I have on additional concern. Is the VGA pass-through cable required for 3D acceleration? I assumed it was, but I am experiencing something that seems to be telling me otherwise.

I have got GTAIII running pretty nicely right now on Win98 with my 12mb Voodoo2 SLI. It gets about 15 - 20 FPS which is pretty playable.

However I just did a test to see if my voodoos are ACTUALLY accelerating the game or not, just to be certain. I plugged my VGA directly into my on-board graphics controller (Intel 82810-dc100) and disabled the Voodoos in Device Manager. Of course, as expected, GTAIII fails to launch. However if I re-enabled the Voodoos but leave the VGA plugged directly into my on-board graphics (no voodoo pass-through used) the game runs equally as well as it does when I have my VGA routed through the Voodoo pass-through. What? Are my cards not being used for D3D then? That is really confusing to me.
Go to Top of Page

Glide
Web Admin

Napoli


24442 Posts

Posted - 27/03/2012 :  16:31:57  Show Profile  Visit Glide's Homepage  Reply with Quote

Hi toddfx,

the System Info related issue is a "known bug" of FastVoodoo2 drivers, but it's a visual problem only: the 24MBs of your Voodoo2 SLI on board memory are OK, of course.

Regarding the pass-through cable, it's required to correctly set-up the graphics subsystem: it manages which video signal feeds the monitor, but not the "properties" of this, like the 3D acceleration. So please use the pass-through cable to connect the VGA output of primary video device (Intel 82810-dc100 in this case) to the first Voodoo2 (the card that is in the PCI slot nearest to cpu) and then the first Voodoo2 to the screen. Of course, you must use a SLI cable to interconnect the Voodoo2 cards...

Regarding the hardware support for Direct3D based games, you can download the utility 3D Control Center from 3dfxzone.it at the following URL:

http://www.3dfxzone.it/dir/3dfx/voodoo2/utilities/

3D Control Center was developed by Matrox for its add-on card M3D, but it works fine also with Voodoo2, allowing to enable the 3dfx SLI subsystem as primary D3D device. However, in many cases the DirectX 3D based games offer a setting in the configuration menu to choose the hardware video device used by the software.

Bye bye

Welcome to 3dfxzone.it Community

Join us! | 3dfxzone.it | hwsetup.it | forumzone.it
Go to Top of Page

ps47
Moderator

Slovakia
1461 Posts

Posted - 30/03/2012 :  21:33:46  Show Profile  Visit ps47's Homepage  Send ps47 an AOL message  Send ps47 an ICQ Message  Reply with Quote
gta3 does not work with a voodoo2, so it is running on the integrated vga.

The 3Dfx Helppage and Game Guide / Voodoo3/4/5 enviromental variables
Go to Top of Page

pierrickuk
Novice

40 Posts

Posted - 31/03/2012 :  04:13:51  Show Profile  Visit pierrickuk's Homepage  Reply with Quote
From what I have read, I was under the impression that it is possible to have 2 monitors plugged on a VGA+Voodoo setup: one monitor on the vga card, the other one on the voodoo. I have never tried this however.
The main point of the pass through cable being to have only one screen.
I will try this as soon as I get my hand on some spare time, as I have all the necessary hardware at home for this.
Go to Top of Page

toddfx
Novice

5 Posts

Posted - 03/04/2012 :  05:28:39  Show Profile  Visit toddfx's Homepage  Send toddfx an AOL message  Reply with Quote
quote:
Originally posted by ps47

gta3 does not work with a voodoo2, so it is running on the integrated vga.



GTA3 did run when I had the Voodoo2s enabled, but when I would disable them in the Device Manager and restart, it would then fail to run. Re-Enabling them would then allow the game to run again. Seems strange indeed, but that was the case...

However now i've installed a Matrox G200 (in addition to my Voodoo2s) and the game will no longer run at all. I'm using the "3D Control Center" tool to make sure the Secondary Video Device is in use, but no luck.

I just don't understand how the game could of possibly run on the integrated graphics (3.0MB) but will not run on either G200 or Voodoo2s.

Edited by - toddfx on 03/04/2012 05:29:12
Go to Top of Page

toddfx
Novice

5 Posts

Posted - 04/04/2012 :  19:24:19  Show Profile  Visit toddfx's Homepage  Send toddfx an AOL message  Reply with Quote
Well I figured out why the Intel 82810 integrated graphics was able to run GTAIII with only 3MB of onboard video memory. That is because it is equipped with Dynamic Video Memory which uses up to 32MB of system memory: http://www.intel.com/support/graphics/sb/CS-010488.htm

And of course now that my G200 only has 8MB and does not borrow from system memory, the game does not like it. Good thing I also ordered the 8MB upgrade module for the G200 :) Should be interesting.

Edited by - toddfx on 04/04/2012 19:25:22
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Print topic
Jump To:

 

Forum Rules

Legal Info

Privacy

Contact Us

3dfxzone.it

HWSetup.it

ForumZone.it

 

All trademarks used are properties of their respective owners - Forum Graphics and Contents 2001 - 2014 3dfxzone.it - Forum Engine Snitz Forums