3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home | Profile | Register | Active Topics | Members | Search | Search with Google | FAQ | 3dfxzone.it
Save Password
Forgot your Password?

 3dfx Hardware & Software
 Voodoo3 and Velocity Setup and tweaking
 Archimedean Dynasty hangs on Voodoo3500 Win98 box
 New Topic  Reply to Topic
 Print topic

Author Previous Topic Topic Next Topic  

Guru Zeb

2 Posts

Posted - 23/07/2011 :  05:17:44  Show Profile  Visit Guru Zeb's Homepage  Reply with Quote
Hi guys
Hope its ok to ask a query like this here, not many places with much expertise in legacy gaming.

After trying for (literally years) to get Archimedean Dynasty and I-War working with a Glide wrapper. On a modern machine IMHO thats only part of the challenge once you get the game running you have the next issue with games like it of no usb sticks working correctly, as old game port sticks used different protocols to the ones used by USB sticks now.

I bit the bullet and build a 'Retro Box', so i could mostly play I-War and its expansion I-War Defiance, which am sure many will agree ranks alongside 3DFX Archimedean Dynasty as THE benchmark for that genre of game.

Retro box runs Win98 SE
has a Voodoo 3500
128mb ram
PIII 1Ghz ( i think PIII in the 500mhz-1Ghz
and a old 16bit Aztec soundcard
As am a packrat i even still had a Saitek x35 flightstick/HOTAS
in mind condition to use. ( Just wish my old CH Combatstick+Throttle still worked)

It works great and it has never missed a beat with I-War. Everything is perfect. Never had to use any variables or switches.
However Archimedean Dynasty is a different matter.
If i start the instant action it works perfectly.
If i start the full game it always hangs at about exactly 4.5mins into the text dialogs, just freezes solid always at about the same time after starting the game. This occurs with both 3DFX and software exes, with and without sound enabled.
Played quite few other old 3DFX games on the Box too.

So am assuming its not a 3DFX or sound issue am having.
Please remember that I-war will happily work all day with no issues at all so its not overheating, general system stability or anything like that.

Back in the day i had both games on a 2x Voodoo2 SLI setup and had no issues. But am assuming its not the Voodoo 3500 as the game behaves the same in software mode.
Am thinking maybe its a too much virtual mem issue or a too much system Ram. Or a Win98 SE problem.

No offence but heres a list of 'Dumb suggestions' that will not help me.
Please do not make any of these dumb suggestions.

Play it in software mode = STFU
Use DOSBox = STFU unless someone has solved the issues of getting it working, but would still leave stick support as a hurdle.
Play Aquanox instead = STFU and wash your mouth out too Boi !!!!

Ok Thanks inadvance
Any helpful suggestions hugely appreciated


Edited by - Guru Zeb on 23/07/2011 05:20:33
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Print topic
Jump To:


Forum Rules

Legal Info


Contact Us





All trademarks used are properties of their respective owners - Forum Graphics and Contents 2001 - 2017 3dfxzone.it - Forum Engine Snitz Forums