3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home | Profile | Register | Active Topics | Members | Search | Search with Google | FAQ | 3dfxzone.it
Save Password
Forgot your Password?

 3dfx Hardware & Software
 Voodoo2 Setup and tweaking
 Win98SE Voodoo2 12MB SLI >51MB Ram Bug?
 New Topic  Reply to Topic
 Print topic

Author Previous Topic Topic Next Topic  


44 Posts

Posted - 22/11/2010 :  19:22:04  Show Profile  Visit H-street's Homepage  Reply with Quote
Anyone run into a bug with having Win98SE , Voodoo2 12Mb SLI and greater than 512Mb or ram?

I getting my final retro gaming PC setup and together I am dual booting both XP and 98SE.

the box contains
A8V Mainboard
AMD 3400+
Pny 6800GT
Dual Voodoo2 SLI 12MB
Soundblaster Audigy

when i try to run with more than 512Mb of DDR1 the control panel won't open for the Voodoo2's and no Glidegame will run.

this does it for all 4 sticks of memory i have.

If i have only a single voodoo2 it works great with 1Gb of DDR
if i have only 512mb of DDR1 it works great with dual voodoo2's

has anyone seen this behaviour before? the only reason i was hoping to have 1 Gb of DDR in the system is for the windows xp gaming.

i have a feeling it has to do with memory addressing with win98se and the 3dfx drivers (the 3dfx drivers will only access memory upto a certain amount, keep in mind that the PCI device is added into the memory pool ontop of the system ram)


3 Posts

Posted - 23/11/2010 :  03:53:39  Show Profile  Visit luckybob's Homepage  Reply with Quote
windows 98 can only address to 256mb of ram
Go to Top of Page


1463 Posts

Posted - 24/11/2010 :  14:19:53  Show Profile  Visit ps47's Homepage  Send ps47 an AOL message  Send ps47 an ICQ Message  Reply with Quote
I think the maximum is (exactly) 512MB.try the unofficial service pack,it should have fixes for these situations: http://www.softpedia.com/get/System/OS-Enhancements/Unofficial-Windows-SE-Service-Pack.shtml

The 3Dfx Helppage and Game Guide / Voodoo3/4/5 enviromental variables

Edited by - ps47 on 24/11/2010 14:20:14
Go to Top of Page


44 Posts

Posted - 30/11/2010 :  20:16:06  Show Profile  Visit H-street's Homepage  Reply with Quote
Thanks for the link, going to try the service pack.

what is odd is that even if i try to limit the amount of ram seen by windows 98 (in the msconfig) it still crashes the SLI setup.

Go to Top of Page


44 Posts

Posted - 22/12/2010 :  16:30:05  Show Profile  Visit H-street's Homepage  Reply with Quote
Well i tried the service pack but no luck but i have tracked down the issue.

it has something to do either with the Audigy and Voodoo2 SLI setup. or a motherboard bug/win98se memory addressing bug with the PCI cards.

if i remove the audigy card it will work fine, or if i remove 1 of the voodoo's it works.

I have tried putting in an X800 Pro instead of the 6800GT and that didn't effect anything, next i will have to try and use a primary video card with less vram (since the vram is still additive to the memory addressing issue)

Go to Top of Page


40 Posts

Posted - 28/12/2010 :  10:39:03  Show Profile  Visit pierrickuk's Homepage  Reply with Quote
Hi there and merry christmas.

First, I would just leave 512 mb of ram in that machine to get the SLI and the Audigy everything working with 98se.
I remember reading -probably in this forum- that the AGP aperture value is kind of important when using Voodoo2, so I would find that info, and set everything else in the bios to default. If you're only gonna play glide games on that box, I'm sure the BIOS default settings will be enough

I am also in the process of setting up my Glide box with dual boot of 98se and xp, albeit with a voodoo5, and it's not always as straightforward as I wish it was.

As for putting back the remaining ram sticks, for win98se, you will need to edit the system.ini and add some lines to limit the memory win98se "sees".

Some reading for you:

I had success setting up the ram the way I wanted, then installed win98se unofficial service pack, and now am back to square one.
My path to success -before the unofficial service pack kicked in and broke it- was to use "msconfig" in win98se in safe mode. All other attempts to edit the file didn't work. Why? I don't know.

In case this is hardware related, my current config is as follows:
Motherboard: Soltek 75drv5
CPU: Athlon XP 2500 (fsb166). not stable at 166 so fsb 133 (1700 mhz)
Memory: 2x512 DDR
Video: Voodoo5 5500 AGP
Sound: some old SB pci
Windows 98 se US (or UK)
WinXP pro fr sp2.

My last personal advice: try to use XP when possible, go back to 98 only if the game doesn't work in XP.

Do you also use this config for DOS games?
Go to Top of Page


44 Posts

Posted - 02/01/2012 :  00:43:50  Show Profile  Visit H-street's Homepage  Reply with Quote
For posterity i finally figured this one out.. running with 1Gb of ram with my voodoo2 sli setup

there is a bug in win98 when >512mb of ram is installed

link to info is here http://answers.google.com/answers/threadview/id/333688.html

the short is you have to limit the systems filecache..

from the link (incase it goes dead)

To warn Windows that you have more than 512MB of memory installed, add
the following line to the [VCache] section of your win.ini file:
MaxFileCache = 524288.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Print topic
Jump To:


Forum Rules

Legal Info


Contact Us





All trademarks used are properties of their respective owners - Forum Graphics and Contents 2001 - 2017 3dfxzone.it - Forum Engine Snitz Forums