3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home | Profile | Register | Active Topics | Members | Search | GoogleSearch | FAQ | 3dfxzone.it
Username:
Password:
Save Password
Forgot your Password?

 Index
 3dfx Hardware & Software
 Voodoo2 Discussions
 Quantum X-24 and Radeon 9700 Anybody fix it yet???
 New Topic  Reply to Topic
 Print topic

Author Previous Topic Topic Next Topic  

Brain
Novice

9 Posts

Posted - 23/05/2004 :  02:50:28  Show Profile  Visit Brain's Homepage  Reply with Quote
Hey just checking in, I posted a little bit ago. Has anybody figured out how to get the Quantum X-24 and the Radeon 9700 or other radeon higher then 9500 to work. I just get MemMap Error or black screen when ever I try to run any 3dfx games or apps. It's a bug with ATI Radeon Cards that are higher then 9500 I believe. I setup a System with a 9100 and it works perfect.

Hows the next driver of FastVoodoo coming along and will that fix that major bug.

Untill then my pretty Quantum X-24 is in my computer just for looks.
Thanks
Brain
ballen1@cox.net
My System
WinXp Pro SP1a
MSI KT333
AMD XP 2100
512 DDR 333MHZ
ATI All In Wonder 9700
Quantum3d X-24
SBLIVE
DX 9.0b
Fast Voodoo 4 Gold
CAT 4.5

PanoramixDruida
Average

Argentina
152 Posts

Posted - 27/05/2004 :  03:32:31  Show Profile  Visit PanoramixDruida's Homepage  Send PanoramixDruida an ICQ Message  Reply with Quote
Look, I don't know if this is a Radeon only problem. I get the same error, and I have a motherboard with nForce2 chipset and a GeForceFX 5200. So, I don't know what's the problem.

Look, try installing the FastVoodoo2 4.0 FX GE drivers http://www.3dfxzone.it/monitor/am/go.asp?url=49

Then, install this patch: http://www.3dfxzone.it/files/download/video/3dfx/voodoo2/fastvoodoo2/2kxp/02/fv2_fix_xp.exe

And tell us what happened.

Good luck!
Go to Top of Page

Brain
Novice

9 Posts

Posted - 27/05/2004 :  06:53:13  Show Profile  Visit Brain's Homepage  Reply with Quote
That's the version I installed, and that fix isnt really a fix. It's the same Glide files that Quantum 3d final release. That works great with a primary video card of a lower Radeon.

I posted a while ago that if you use the original glide files that quantum gave out and then use fast voodoo everything works. For older primary cards that is.

Oh well.
Still waiting for somebody to say their working on it in the next version of FastVoodoo
Thanks
Brain
Go to Top of Page

PanoramixDruida
Average

Argentina
152 Posts

Posted - 27/05/2004 :  18:24:18  Show Profile  Visit PanoramixDruida's Homepage  Send PanoramixDruida an ICQ Message  Reply with Quote
Some days ago, Glide told me that I'd try uninstalling the primary video drivers -he wanted to see something I don't know/understand-; in your case the Radeon ones. And then, try to play some Glide/OpenGL game -using the Voodoo2- to see if the Mapmen returned an error when trying to map memory still happens.

He said:

quote:
The main card has a physical address which gets mapped by winblows. The V2 has another physical address. During initialization, Glide2x/3x will try to map the physical address into linear space. It either doesn't find the space (very unlikely), tries to map over an allocated area (stupid) or doesn't do something right from the NT point of view (I guess NT takes memory protection way to serious - every sane person who feels THAT paranoid should switch to Linux, anyway).



Try doing this, and tell us what happened. Good luck!
Go to Top of Page

Avenger
Novice

38 Posts

Posted - 05/07/2004 :  16:19:11  Show Profile  Visit Avenger's Homepage  Send Avenger an ICQ Message  Reply with Quote
Koolsmoky is on it, he just hasn't got time for it right now. Since I have that exact constellation (Radeon 9600 XT primary and X-24), we've been working on a solution (well, he is, with my feedback). Current status is that memmap succeeds on the primary V2, but still fails on the secondary. I'm confident that it'll get fixed in time.
Go to Top of Page

Avenger
Novice

38 Posts

Posted - 01/12/2004 :  17:19:46  Show Profile  Visit Avenger's Homepage  Send Avenger an ICQ Message  Reply with Quote
Update !
My X-24 is mostly working as of today. In my case it was a resource conflict with my network card.

Edited by - Avenger on 01/12/2004 17:20:31
Go to Top of Page

koolsmoky
Moderator

101 Posts

Posted - 12/12/2004 :  22:11:02  Show Profile  Visit koolsmoky's Homepage  Reply with Quote
http://www.3dfxzone.it/enboard/topic.asp?TOPIC_ID=718&whichpage=3

-KoolSmoky
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Print topic
Jump To:

 

Forum Rules

Legal Info

Privacy

Contact Us

3dfxzone.it

HWSetup.it

ForumZone.it

 

All trademarks used are properties of their respective owners - Forum Graphics and Contents 2001 - 2014 3dfxzone.it - Forum Engine Snitz Forums