3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home | Profile | Register | Active Topics | Members | Search | Search with Google | FAQ | 3dfxzone.it
Username:
Password:
Save Password
Forgot your Password?

 Index
 3dfx Hardware & Software
 Voodoo4/5 Setup and tweaking
 SFFT alpha drivers - V3/4/5 - Join to Testing
 New Topic  Reply to Topic
 Print topic

Previous Page | Next Page
Author  Topic Next Topic
Page: of 123

benna
Average

Italy
376 Posts

Posted - 19/04/2007 :  14:42:35  Show Profile  Visit benna's Homepage  Reply with Quote
I tried alpha46 under WinXP x64 and the results are very impressive
UT99 works perfectly in Glide mode, the framerate is 60fps constant but i hadn't activate vSync; in windowed mode the game turns in software rendering without any advice
Also FreeSpace2 works well in Glide rendering, but it have some LOD problems: far ships appears black, when closing the textures appears fading
Other DX games works like under WinXP x86

I keep having problems with Glide under WinXP x86, even after i used Driver Cleaner; maybe i should format...

my PC:
AMD Athlon64 3200+ - ASUS K8V-Deluxe - 1GB DDR400 - 3DFX Voodoo 5 5500 PCI

3DAnalyze user guide http://www.3dfxzone.it/dir/articles/template.php?id=5
Go to Top of Page

Rolo01
Experienced

Germany


508 Posts

Posted - 20/04/2007 :  20:18:43  Show Profile  Visit Rolo01's Homepage  Reply with Quote
quote:
Originally posted by max1024

Is possible 2 rus 3DM2001 on new SFFT alpha drivers ?



Yes, it is :
Image Insert:

63.29 KB

Runs fine on Voodoo4 AGP.
Go to Top of Page

Raff3DC
Average

Germany


348 Posts

Posted - 21/04/2007 :  14:22:10  Show Profile  Visit Raff3DC's Homepage  Reply with Quote
If I recall correctly, it was always possible. But on my main rig it never worked ... dunno why. Just a black screen after loading the gametest, then I had to reset. My V56k machine runs fine.

But: Windows 98 SE is faster than XP in terms of 3DMark speed.

Greetings,
Raff

The biggest Voodoo5 6000 test ever: http://3dcenter.de/artikel/voodoo5-6000/
Go to Top of Page

Raff3DC
Average

Germany


348 Posts

Posted - 22/04/2007 :  14:02:43  Show Profile  Visit Raff3DC's Homepage  Reply with Quote
Btw: World of Warcraft runs without big bugs on a Voodoo3 with Alpha 46. When I had tested the game maybe one year ago, there were many texture problems (on Voodoo5 too). They are gone with present drivers, but the shadow maps are white instead of black and you can't see the ability icons ... I think it's due to hardware limits.

Look here:


Greetings,
Raff

The biggest Voodoo5 6000 test ever: http://3dcenter.de/artikel/voodoo5-6000/

Edited by - Raff3DC on 22/04/2007 14:10:09
Go to Top of Page

Hunter
Novice

Brazil


5 Posts

Posted - 22/04/2007 :  23:23:54  Show Profile  Visit Hunter's Homepage  Send Hunter an ICQ Message  Click to see Hunter's MSN Messenger address  Reply with Quote
quote:
Originally posted by Glide

To all:

Is possible to give feedbacks about GLide based games, comparing SFFT current release performance and compatibility to those of some previus versions like SFFT Alpha 45 or minor?

Thanks in advance.

Bye Bye



After Alpha 42 any Glide app. nor even initializes. I'm using a V3 2K (my 3K burnt ) w/ Win2K SP4 + Update Rollup + all fixes. DirectX 9.0c version is the most recent one before April's update. The "problem" probally resides on the main drivers, because de Glide libraries are the same.

I've attached a DrWatson log in wich I was trying to run ePSXe with Lewpy's plugin (works ok w/ Alpha 42 or below).

Edited by - Hunter on 22/04/2007 23:28:37
Go to Top of Page

SuperFurryFurryThing
Average

386 Posts

Posted - 24/04/2007 :  14:56:58  Show Profile  Visit SuperFurryFurryThing's Homepage  Reply with Quote
You should be able to run any glide combination you want with the sfft drivers. The ones that are shipped with it are the only ones I have found that run under Win XP 64 and also are the only ones I have seen that run Arifix Dogfighter ok. You can always run other glides if you have problems with specific applications.

SFFT
Go to Top of Page

Glide
Web Admin

Napoli


26595 Posts

Posted - 24/04/2007 :  18:10:14  Show Profile  Visit Glide's Homepage  Reply with Quote
- Rolo01:

Thank you for your report about 3DMark 2001.


About GLide games on Win32 OSes, as SFFT writes, we can replace GLide libraries packed with Alpha 46 using other stable releases. It isn't a big problem because we will not have new Glide games ;)

Good posting,

Bye

Welcome to 3dfxzone.it Community

Join us! | 3dfxzone.it | hwsetup.it | forumzone.it
Go to Top of Page

Hunter
Novice

Brazil


5 Posts

Posted - 24/04/2007 :  21:04:04  Show Profile  Visit Hunter's Homepage  Send Hunter an ICQ Message  Click to see Hunter's MSN Messenger address  Reply with Quote
quote:
Originally posted by Glide

About GLide games on Win32 OSes, as SFFT writes, we can replace GLide libraries packed with Alpha 46 using other stable releases. It isn't a big problem because we will not have new Glide games ;)

Good posting,

Bye



Yes, I tried it but without success. I tested SSFT 46 either with the offical 3dfx Glide libraries (the last ones released for 2k/xp) or the ones shipped w/ the drivers. I also tried the Koolsmoky releases. The point is that any Glide 3x library works w/ SSFT 43 and above. It simply crashes (with an ilegal task). In other hand, every single library I've tried w/ 42 and below does work perfectly.

It's quite weird . A question: Is the Glide access somewhat managed by the display driver or the applications can access it directly? Isn't it supposed to be a independent API?
Go to Top of Page

SuperFurryFurryThing
Average

386 Posts

Posted - 25/04/2007 :  14:57:12  Show Profile  Visit SuperFurryFurryThing's Homepage  Reply with Quote
Well that is odd, the supplied drivers definitley work, under 32 bit aswell as 64 bit, I seem to recall that the Glide Xp releases used with AmigerMerlin work aswell under 32 bit. It has been a while since I tested them. The supplied ones are based on Koolsmokeys anyway, so Koolsmokeys should work. If other glides have problems with bad Handle issues, then they may not work. the Process Handle interface is no longer supported, so older versions of glide may be broken. The glide interface is not driver independant no user mode interface to hardware can be. I suspect that you may not be testing with the glide dll's that you think you are. At least 3 of them should work. I can't say that I tested the last 3dfx w2k releases, I think that I tested XP compatible ones, as I seem to recall that the Process Handle Interface doesn't work under XP anyway, at least I think that I saw that claimed in one of the Glide sources, which incorporated code to get round the issue.

SFFT
Go to Top of Page

Hunter
Novice

Brazil


5 Posts

Posted - 25/04/2007 :  20:21:18  Show Profile  Visit Hunter's Homepage  Send Hunter an ICQ Message  Click to see Hunter's MSN Messenger address  Reply with Quote
Glide 3x versions I tested:

3.10.00.0658 - The last on supplied by 3dfx for Win2k;
3.20.0.1016 - Latest Glide XP release. It gives me a "HWCEXT_GETLINEARADDR Failed" error message;
3.10.00.2610 - Koolsmoky latest "official" release;
3.10.00.2610 - Koolsmoky based included w/ Alpha 46, but with compiling date of 03/09/07.

These four crashes with 43 and above (yes, I tried w/ all of them, both Glides and display drivers) but do not with 42 and below. Maybe under 2K environments the display driver (or Glide?) needs this old Procces Handle Interface to correctly manage Glide routines, whereas under XP alternate access methods can be used, since de Handle Interface doesn't work properly. Do you remember of have done any significant change on display driver or Glide 3x library after 42th release?

Thanks for the good work, the Direct3D/Draw core updates are great.

Edited by - Hunter on 25/04/2007 20:40:42
Go to Top of Page

SuperFurryFurryThing
Average

386 Posts

Posted - 26/04/2007 :  11:03:14  Show Profile  Visit SuperFurryFurryThing's Homepage  Reply with Quote
The problem is that I have tested these on Win2k, or at least 3 of them and they work. What card are you using, and how are you testing them, i.e. with what programmes. I presume that if you are using a native glide application that they will be using glide2 anyway, and my opengl testing (which uses glide3x) works. The later glides emulate the process handle logic internally so should work without its support in the driver, and as someone has pointed out UT99 works on X64 without the Process handle interface, using the same glide dlls that are used on XP and W2k.

SFFT
Go to Top of Page

Hunter
Novice

Brazil


5 Posts

Posted - 27/04/2007 :  02:59:38  Show Profile  Visit Hunter's Homepage  Send Hunter an ICQ Message  Click to see Hunter's MSN Messenger address  Reply with Quote
I just have 2 applications that can uses Glide atm: ePSXe (with Lewpy's Glide 3x plugin) and a Nintendo 64 emulator (Project64/1964/etc) using Glide 64 plugin (wich also uses Glide3x). Both of them show the same odd behavior.

Well, to test I delete "3dfxvs.dll" and "glide3x.dll" from System32 and "3dfxvsm.sys" from System32/Drivers directories, substituting them with the desired version to test. So I reboot the system and run DxDiag tool to check if the drivers were correctly recognized and are in use. The only combination that produces a successfully result is Alpha 42 or below w/ any Glide 3x library.

Is it possible that some registry entry is the villain here?

PS: I'm using a Voodoo 3 2000 AGP, since my 3k burnt for god.

Edited by - Hunter on 27/04/2007 03:00:47
Go to Top of Page

Radware59
Novice

USA
1 Posts

Posted - 28/04/2007 :  05:29:24  Show Profile  Visit Radware59's Homepage  Reply with Quote
This driver works better than the windows xp driver.
Some games that wouldn't work before will run now.
Other games that worked fine have serious problems with this driver.
I get incorrect textures drawn on the characters in the game.
This example image is from one game that didn't work at all before the driver update. It appears fine in windowed mode, but in full-screen it appears as shown on the right.


Running Windows XP home edition DirectX 9.0c
Pentium III 1 GHz Matsonic MS7177C Motherboard
Voodoo5 5500 64 MB 512 MB Sdram

It might be best not to mention the game titles here. I could e-mail them if necessary.
Are there any adjustments that might correct this kind of problem?
If not, I hope at least this info can be of some value to future improvements.


Go to Top of Page

ps47
Skilled

Slovakia
1463 Posts

Posted - 01/05/2007 :  11:00:22  Show Profile  Visit ps47's Homepage  Send ps47 an AOL message  Send ps47 an ICQ Message  Reply with Quote
try disabling texture management with this small tool (directly from SFFT): https://www.3dfxzone.it/public/uploaded/SuperFurryFurryThing/2006225183415_tmutils.zip

btw,posting the names of the games IS a good idea ;)

The 3Dfx Helppage and Game Guide / Voodoo3/4/5 enviromental variables

Edited by - ps47 on 01/05/2007 11:02:20
Go to Top of Page

mcmagostini
Initiate

Brazil


64 Posts

Posted - 01/05/2007 :  16:53:26  Show Profile  Visit mcmagostini's Homepage  Send mcmagostini an ICQ Message  Click to see mcmagostini's MSN Messenger address  Reply with Quote
Maybe it's because the games is rated Adults Only, judging by the
picture... Maybe some game about some mansion of some big guy
who rules some famous adult magazine.



AmigaMerlin / SFFT / MesaFX
Sempron64 3000+, 512MB DDR400 2,5-3-3-11
Voodoo5 5500 PCI (Rev 3100)
ASUS K8N4-E

Edited by - mcmagostini on 01/05/2007 16:54:56
Go to Top of Page
Page: of 123  Topic Next Topic  
Previous Page | Next Page

 New Topic  Reply to Topic
 Print topic
Jump To:

 

Forum Rules

Legal Info

Privacy

Contact Us

3dfxzone.it

HWSetup.it

ForumZone.it

 

All trademarks used are properties of their respective owners - Forum Graphics and Contents 2001 - 2017 3dfxzone.it - Forum Engine Snitz Forums