3dfxzone.it ~ SFFT Drivers ~ MesaFX ~ 3D-Analyze ~ 3dfx Headlines ~ 3dfx Cards ~
Home | Profile | Register | Active Topics | Members | Search | Search with Google | FAQ | 3dfxzone.it
Username:
Password:
Save Password
Forgot your Password?

 Index
 3dfx Hardware & Software
 Voodoo4/5 Setup and tweaking
 SFFT alpha drivers - V3/4/5 - Join to Testing
 New Topic  Reply to Topic
 Print topic

Previous Page | Next Page
Author  Topic Next Topic
Page: of 123

FBS
Initiate

Canada
80 Posts

Posted - 15/10/2004 :  04:12:05  Show Profile  Visit FBS's Homepage  Reply with Quote
I am not sure what I am talking about either. I am just looking at way to solve the texture blurr problem that is related to some third party planes I have tried.
First I want to say thanks for the tip, since I changed my config file to use DXT3 texture in my sim, the game has been running very well. I had done this some time ago when you first mentioned it.
I also solved the problem of the texture blurr. It seems that some of the formats of the bitmaps of the plane model I was using, where in 32bit and others where in a DXT3. Looks like the card or drivers did not like modeling up a plane model in two different type of texture format. I converted all the third party formats to DXT3 and presto no more blurr.
Now for the Kneeboard, I am trying to look for this particular bit map in the game to check its format, maybe this is the isseu. Though I don't think so because the kneeboard only works with single chip???

FBS

Edited by - FBS on 15/10/2004 04:12:47
Go to Top of Page

FBS
Initiate

Canada
80 Posts

Posted - 15/10/2004 :  09:47:18  Show Profile  Visit FBS's Homepage  Reply with Quote
More thought on the ability of the card and or drivers to display multiple texture formats. You see a couple posts back I mentioned.
quote:
by the way what are DXT3 textures? It seems some people can load them on their system but if I try this in my PC, my game crashes.

I have been checking the texture formats throughout the game and it seems that the default game aircraft are in DXT3 and the textures for the scenery are 32bit. Why that is I have no idea and maybe this is something that only Microsoft can answer. This is most likely the answer to why when I had loaded a set of DXT3 cloud textures in the game scenery, the game would not load and crash to desktop. Is it possible that the "Render to Texture" option in the game display setting is not working with the SFFT drivers? I believe this is the purpose of this setting; It makes multiple texture and makes them into one texture? Or is this setting not functional because of the multiple processing chips of the Voodoo5 card would make it impossible to render an image with two types of bit formats? Is there any synchronization in the two chips or am I off the topic, because the last thought on this is why did even in single chip mode did I still get a blur problem.
Have a nice day
Go to Top of Page

SuperFurryFurryThing
Average

386 Posts

Posted - 16/10/2004 :  01:30:02  Show Profile  Visit SuperFurryFurryThing's Homepage  Reply with Quote
The short answer to the multiple texture rendering is that I havn't got a clue. I have simply got then to dowmload correctly.

SFFT
Go to Top of Page

SuperFurryFurryThing
Average

386 Posts

Posted - 16/10/2004 :  01:45:51  Show Profile  Visit SuperFurryFurryThing's Homepage  Reply with Quote
To vykupitel
The chip detecion uses standard NT kernel functions, I would suggest that you talk to the AGP2PICI card manufacturers about NT Driver/compatibility.

SFFT
Go to Top of Page

vykupitel
Initiate

Czech Republic


86 Posts

Posted - 16/10/2004 :  19:25:40  Show Profile  Visit vykupitel's Homepage  Reply with Quote
quote:
Originally posted by SuperFurryFurryThing

To vykupitel
The chip detecion uses standard NT kernel functions, I would suggest that you talk to the AGP2PICI card manufacturers about NT Driver/compatibility.
SFFT


Yes, this problem is in the NT kernel, but I think that there could be some chance to do some hack for detection of all four chips. AGP2PCI is just riser card with no drivers for it, it only does some voltage changes for 5V PCI slot. The problem would be definitely in the NT kernel, because this confiration run flawlessly in Win9x. I hate dual boot configuration with Windows. It is just cosmetical change with lot of work but this will be very usefull for all owners of AGP2PCI card. I think that Hank also could say something in this.

AthlonXP 1.86GHz@2.2GHz (barton), 1024MB PC400 RAM,MSI KT6-Delta LSR,
Voodoo5 6000 rev. 3700 A1 + Voodoo4 4200 AGP(Daytona) and many more...

Edited by - vykupitel on 18/10/2004 08:46:14
Go to Top of Page

omega_supreme
Average

Netherlands


149 Posts

Posted - 18/10/2004 :  22:46:24  Show Profile  Reply with Quote
@SFFT Since Amigamelin now uses your new d3d core maybe you can help me out with Tribes Vengeance. The game needs HW TnL and PixelShader. However the games starts up after an error message. Menu and all work just fine but when the game loads a level (at any detail) it jams after a few seconds. No mater what I try (3danalyze etc.) it just jams. The 3dfx tools are i bit different from amigas that i was used (no force 32 bbp for example) So maybe you know a solution for this. A demo can be downloaden here :

http://www.net.bialystok.pl/gry/tribesv_spdemo_en.exe
Go to Top of Page

osckhar
Average

Spain


334 Posts

Posted - 18/10/2004 :  23:55:04  Show Profile  Visit osckhar's Homepage  Reply with Quote
@SFFT,
I have tried the game VIETCONG (FULL, not Demo), under Core D3D SFFT Alpha 15 but there are a lot ARTIFACTS! Can you fix it?

ps. The same game works perfectly under Win98SE and Razeil Drivers Evo 1.00.16.

Regards,
Oscar

- V6k Team -
¿Leyenda? ¿Mito? ¿Ficción? No... ¡Realidad!


Go to Top of Page

osckhar
Average

Spain


334 Posts

Posted - 21/10/2004 :  00:02:15  Show Profile  Visit osckhar's Homepage  Reply with Quote
@SFFT,
I have problems using the SFFT Alpha 15. Well, I get a SCREEN BLUE sometime when I want to play (It automatically reboot). This mistake does reference about 3dfxvs.dll, look the following:

3dfxvs.dll Page_Fault_in_nonpagedarea

STOP:0x0000008E (OXC 0000005, OXBFA4 11F0, 0X F1FEBC4C, 0X00000000)
3dfxvs.dell - adress BFA411F0 base at BF9D3000 DateStamp 4169aca3


What meaning have all this?

Regards,
Oscar

- V6k Team -
¿Leyenda? ¿Mito? ¿Ficción? No... ¡Realidad!


Go to Top of Page

SuperFurryFurryThing
Average

386 Posts

Posted - 21/10/2004 :  00:20:51  Show Profile  Visit SuperFurryFurryThing's Homepage  Reply with Quote
Vietcong doesn't work in DX8 mode on a V5. It seems to work in DX7 Mode. You need to set the textures in system memory option.

SFFT
Go to Top of Page

LogicalMadness
Novice

21 Posts

Posted - 21/10/2004 :  05:52:24  Show Profile  Visit LogicalMadness's Homepage  Reply with Quote
Hello SFFT,
Do you have any plans to fix the SSTH3_SCREENSHOT_TOGGLE_KEY and SSTH3_AAJITTER_TOGGLE_KEY under D3D so that screen shots and AA jittering work?
Go to Top of Page

algeeba
Novice

17 Posts

Posted - 21/10/2004 :  19:46:20  Show Profile  Visit algeeba's Homepage  Reply with Quote
I have the same problem-automatic reboot in W2K with Core D3D SFFT Alpha 15. I reinstalled the drivers, set to DX7 mode and the game worked (textures are in system memory). I exited the game, restarted the game, and the computer rebooted. After that first reboot I couldn't get the game running again. It would always reboot the computer and it alway happened right after the loading bar finished. I set to DX7 mode again, rebooted, started the game but it didn't work. I didn't run DxDiag to see if that would fix the problem but I'm pretty sure re-installing the drivers would. No problems with the latest Evo drivers and Win98.

Keep up the great work. All you guys (SFFT, Amiga, Dborca, Kool, Raziel, etc.) are doing what a lot of people thought couldn't be done - keeping 3dfx going.

Thanks.


------------------------------------------
Athlon XP-M 2500+ @ 2.3 GHZ
ABIT NF7-S Rev 2.0
512 MB Crucial memory
Win98 SE w/W2K dual boot
Directx 9.0b
Aureal Vortex 2 PCI sound card
Voodoo5 5500 PCI
Go to Top of Page

SuperFurryFurryThing
Average

386 Posts

Posted - 22/10/2004 :  00:38:55  Show Profile  Visit SuperFurryFurryThing's Homepage  Reply with Quote
You need to reboot the machine after setting DX7 Mode or DX8 mode, once set and the machine reboot the mode stays set.

SFFT
Go to Top of Page

ggab
Average

Argentina


294 Posts

Posted - 25/10/2004 :  01:45:24  Show Profile  Visit ggab's Homepage  Send ggab an ICQ Message  Click to see ggab's MSN Messenger address  Reply with Quote
i can't play Enter the Matrix...

i've tried Set3title.exe & restart, but no-way

the game starts (both windowed & full sc)
says:

Error:
MSG_GRAPHICS_BUFFER_FAILURE

then

D3DControl::Initializa() - Failed to create shadow buffer

then

can't creat movie-texture (something similar....)
[the short movie is ok with raziel's evos]

and, when i choose New Game, it goes back to Desktop :(

What are the "steps to play it" in a v4, or in a v5 with 'one single chip'?
Go to Top of Page

SuperFurryFurryThing
Average

386 Posts

Posted - 25/10/2004 :  22:51:52  Show Profile  Visit SuperFurryFurryThing's Homepage  Reply with Quote
Well it worked ok for me under win2k in fullscreen mode, although it only ran sometimes, and in wondowed mode on XP on a V5. You do get some errors reported about failing to create buffers, but I found that it you ignored them it worked. I presume that you have downloaded and applied the appropriate patch for your OS.

SFFT
Go to Top of Page

ggab
Average

Argentina


294 Posts

Posted - 25/10/2004 :  23:16:21  Show Profile  Visit ggab's Homepage  Send ggab an ICQ Message  Click to see ggab's MSN Messenger address  Reply with Quote
yes, 1.2 path from intel´s card and in winXP.....

so, no speciald settings, no?
Go to Top of Page
Page: of 123  Topic Next Topic  
Previous Page | Next Page

 New Topic  Reply to Topic
 Print topic
Jump To:

 

Forum Rules

Legal Info

Privacy

Contact Us

3dfxzone.it

HWSetup.it

ForumZone.it

 

All trademarks used are properties of their respective owners - Forum Graphics and Contents © 2001 - 2017 3dfxzone.it - Forum Engine © Snitz Forums